ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Having a problem with [closed]

asked 2013-08-16 05:33:42 -0500

rnunziata gravatar image

updated 2013-08-16 14:58:02 -0500

Firs let me ask if this is the right forum or is this better placed in gazebosim forum. I have a post there on this also.

I believe this is the plugin that should be processing rostopic pub commands for joints as described in:

Update: Originally I was having an issue with the pid setting as in the tutorial pid: {p: 100.0, i: 0.01, d: 10.0} The model would launch itself into the air at some infinite distance. So I changed them to zeros and this kept the model in place in gazebo when I brought up the controllers. On a long shot I changed the pid setting and found that the setting below also worked and kept the model in place when the controllers can up.

pid: {p: 0.001, i: 0.001, d: 0.001} NOW however when I issue the line command ....everything works and joint moves. But why does my model jump off the grid with the setting in the tutorial? And a pid (000) stops the joint command msg from working but still allows the setForce in the joint tab to work.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by rnunziata
close date 2013-08-16 15:53:04


Please provide specific error messages not paraphrases.

tfoote gravatar image tfoote  ( 2013-08-16 08:49:07 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-08-16 15:52:39 -0500

rnunziata gravatar image

incorrect PID setting cause commands to be ignored.

edit flag offensive delete link more

answered 2013-08-16 12:29:02 -0500

Dave Coleman gravatar image

updated 2013-08-16 14:29:03 -0500


I just went through and updated the entire gazebo_ros_control tutorials with my lastest work, I added more details and clarified some of the concepts. I tested all the RRBot code and I encourage you to review the changes in the tutorial or on the github demo. This has been one of my main projects this summer while an intern at OSRF.

Concerning your question, I don't think its a big deal that is says "unknown type" - it always does this for me. I don't know why it does that but I think its an issue with lower level ROS stuff and not with the Gazebo code. Is it causing you issues? With everything running correctly for RRBot I get this output from rosnode info gazebo - which seems to be the same as your output.

The command from the tutorial for publishing to joint controller should work:

rostopic pub -1 /rrbot/joint1_position_controller/command std_msgs/Float64 "data: 1.5"

edit flag offensive delete link more


I have reviewed the tutorial and from what I can see only the yaml file changed , I applied these changes and still have not been able to get the joint to move by publishing a command via the plugin. Has anyone else tried the use of the plugin on a model?

rnunziata gravatar image rnunziata  ( 2013-08-16 14:14:36 -0500 )edit

Question Tools

1 follower


Asked: 2013-08-16 05:33:42 -0500

Seen: 872 times

Last updated: Aug 16 '13