Ask Your Question
1

Autocompletion doesn't work via ssh

asked 2013-08-11 23:09:18 -0600

da-na gravatar image

updated 2013-11-18 16:54:21 -0600

tfoote gravatar image

Hello! For some reasons when I use ssh connection autocompletion with ros-commands doesn't work. On the original computer tab completion works, but when I connect to it via ssh I cannot use tab completion :(

I have "source /opt/ros/fuerte/setup.bash" in my .bashrc

I get the following error, after writing roscd [+tab]

roscd terminate called after throwing an instance of 'std::runtime_error' what(): locale::facet::_S_create_c_locale name not valid terminate called after throwing an instance of 'std::runtime_error' what(): locale::facet::_S_create_c_locale name not valid

Anyone had the same problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
6

answered 2013-08-11 23:24:48 -0600

da-na gravatar image

Okey, the answer is here (written by KruseT): http://answers.ros.org/question/53353/autocomplete-not-working-anymore/?comment=72208#comment-72208

ANSWER

export LC_ALL="C" maybe put it in your .bashrc

edit flag offensive delete link more

Comments

got a similar error for rospack profile with export LC_NUMERIC="en_US.UTF-8"

jmainpri gravatar imagejmainpri ( 2015-12-07 10:50:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-11 23:09:18 -0600

Seen: 2,194 times

Last updated: Aug 11 '13