Ask Your Question
0

Catkin make with Hydro issues?

asked 2013-07-29 04:28:28 -0500

allenh1 gravatar image

updated 2013-07-29 08:12:43 -0500

Hello all,

I'm trying to build some code in Hydro, and I'm having some trouble. Catkin was working well with the code the other day, and now I'm having issues for some reason. I have not altered any of the code in p2os, nor have I altered vanderbilt-ros-pkg, so it should at least build those two...

I tried to make a new catkin workspace, and the devel directory was not created. Did I screw up some environment variables, or is this just a difference in Hydro? Here's some output.

allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ catkin_init_workspace 
Creating symlink "/home/allenh1/ros_ws/src/CMakeLists.txt" pointing to "/opt/ros/hydro/share/catkin/cmake/toplevel.cmake"
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ ls
CMakeLists.txt  p2os  rqt_p2os_controller  vanderbilt-ros-pkg
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ cd ../
allenh1@allenh1-Aspire-1830T:~/ros_ws$ catkin_make
Base path: /home/allenh1/ros_ws
Source space: /home/allenh1/ros_ws/src
Build space: /home/allenh1/ros_ws/build
Devel space: /home/allenh1/ros_ws/devel
Install space: /home/allenh1/ros_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/allenh1/ros_ws/build"
####
####
#### Running command: "make -j4 -l4" in "/home/allenh1/ros_ws/build"
####
allenh1@allenh1-Aspire-1830T:~/ros_ws$ ls
build  src

I have done your suggestions to know avail before posting the output above, but I reproduced the process below (in its entirety).

allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ rm  -f CMakeLists.txt && rm -rf ../build
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ ls
p2os  rqt_p2os_controller  vanderbilt-ros-pkg
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ cd p2os
allenh1@allenh1-Aspire-1830T:~/ros_ws/src/p2os$ ls
CMakeLists.txt  p2os_dashboard  p2os_launch  p2os_urdf  stack.xml
Makefile        p2os_driver     p2os_teleop  README.md
allenh1@allenh1-Aspire-1830T:~/ros_ws/src/p2os$ cd p2os_driver
allenh1@allenh1-Aspire-1830T:~/ros_ws/src/p2os/p2os_driver$ ls
CMakeLists.txt         include   manifest.xml  p2os-joystick-teleop.xml  src
CMakeLists.txt.backup  Makefile  msg           package.xml
allenh1@allenh1-Aspire-1830T:~/ros_ws/src/p2os/p2os_driver$ cd ~/ros_ws/src
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ ls
p2os  rqt_p2os_controller  vanderbilt-ros-pkg
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ ls ../
src
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ catkin_init_workspace
Creating symlink "/home/allenh1/ros_ws/src/CMakeLists.txt" pointing to "/opt/ros/hydro/share/catkin/cmake/toplevel.cmake"
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ ls
CMakeLists.txt  p2os  rqt_p2os_controller  vanderbilt-ros-pkg
allenh1@allenh1-Aspire-1830T:~/ros_ws/src$ cd ../
allenh1@allenh1-Aspire-1830T:~/ros_ws$ ls
src
allenh1@allenh1-Aspire-1830T:~/ros_ws$ catkin_make
Base path: /home/allenh1/ros_ws
Source space: /home/allenh1/ros_ws/src
Build space: /home/allenh1/ros_ws/build
Devel space: /home/allenh1/ros_ws/devel
Install space: /home/allenh1/ros_ws/install
####
#### Running command: "cmake /home/allenh1/ros_ws/src -DCATKIN_DEVEL_PREFIX=/home/allenh1/ros_ws/devel -DCMAKE_INSTALL_PREFIX=/home/allenh1/ros_ws/install" in "/home/allenh1/ros_ws/build"
####
-- The C compiler identification is GNU 4.7.3
-- The CXX compiler identification is GNU 4.7.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found PythonInterp: /usr/bin/python (found version "2.7.4") 
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by ...
(more)
edit retag flag offensive close merge delete

Comments

Your output indicated that catkin_make was not even executing cmake. Please remove the build folder, run catkin_make again and post the full output of that command.

Dirk Thomas gravatar imageDirk Thomas ( 2013-07-29 07:20:23 -0500 )edit

One minor thing: you don't have to call `catkin_init_workspace` explicitly. It will happen automatically when invoking `catkin_make`.

Dirk Thomas gravatar imageDirk Thomas ( 2013-07-29 08:21:23 -0500 )edit

Are you sure that you are using the latest versions of packages? The cmake output seems to lack a lot of information between `Found PythonInterp` and `Configuring done`. You might want to run `sudo apt-get update && sudo apt-get dist-upgrade`. Can you also run the following command to list all packages: python -c "import catkin_pkg.packages; print(catkin_pkg.packages.find_packages('.').keys())"

Dirk Thomas gravatar imageDirk Thomas ( 2013-07-29 08:27:22 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-07-29 07:27:20 -0500

William gravatar image

Try removing the CMakeLists.txt in the src folder, as well as the build folder and run catkin_make again.

Also assert that you have the correct version of things in those folders, especially check that there are package.xml's there, because it seems like catkin_make is not finding any packages, and the above output looks like that is not the first time you've run on an empty workspace with that build folder.

edit flag offensive delete link more
0

answered 2014-01-07 11:55:46 -0500

Solved this. You have to deleted the CMakeLists.txt in the src folder AND the CMakeCache.txt in the src folder. Then, you also have to sudo rm -rf the catkin_ws/build folder.

Once that is done, try doing catkin_make in the catkin_ws/ directory.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-29 04:28:28 -0500

Seen: 626 times

Last updated: Jan 07 '14