ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Rosrun executable not found [closed]

asked 2013-07-23 15:27:38 -0600

atp gravatar image

updated 2013-07-24 09:04:43 -0600

lindzey gravatar image

I'm trying to run some code using rosrun on Fedora 19 (the same code works on Ubuntu). This is the error:

find: invalid mode ‘+111’
[rosrun] Couldn't find executable named fitting below /home/andreas/catkin_ws/src/fitting
[rosrun] Found the following, but they're either not files,
[rosrun] or not executable:
[rosrun]   /home/andreas/catkin_ws/src/fitting

The executable is in /devel/lib, and echo $ROS_PACKAGE_PATH gives:

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by atp
close date 2014-04-09 12:02:53

2 Answers

Sort by » oldest newest most voted

answered 2013-07-23 22:05:32 -0600

lindzey gravatar image

updated 2013-07-24 08:25:52 -0600

You say that the executable is in /devel/lib - I assume that you mean /home/andreas/catkin_ws/devel/lib? Are you manually setting the ROS_PACKAGE_PATH, or doing so by sourcing a catkin-generated setup file?


To address something that came up in the comments: You shouldn't need to source both ~/ros_catkin_ws/install_isolated/setup.bash and ~/catkin_ws/devel/setup.bash. Assuming that you had sourced ~/ros_catkin_ws/install_isolated/setup.bash when you first created the catkin workspace as indicated in the tutorial, in all subsequent terminals devel/setup.bash on its own is sufficient. See section 2.5 in the conceptual overview.

edit flag offensive delete link more


You are right about the file path. I sourced catkin_ws/devel/setup.bash. So, ROS_PACKAGE_PATH needs to point to devel/lib?

atp gravatar image atp  ( 2013-07-24 02:33:08 -0600 )edit

No it does need to point to catkin_ws/src

Lucile gravatar image Lucile  ( 2013-07-24 03:46:46 -0600 )edit

So, everything seems to be correct? Maybe I forgot to do sth in general ...

atp gravatar image atp  ( 2013-07-24 04:20:06 -0600 )edit

You did source both /opt/ros/groovy/setup.bash and devel/setup.bash ? Can you do "ls -l" in fitting folder to check the rights you have and if you have the right to execute your programm. If you don't have them - it would be quite odd but not impossible - use chmod to set your file as executable.

Lucile gravatar image Lucile  ( 2013-07-24 04:32:42 -0600 )edit

Yes, I sourced both of them, although the 1st one is: source ~/ros_catkin_ws/install_isolated/setup.bash (see ls -l within devel/lib/fitting gives: total 720 -rwxrwxr-x. 1 andreas andreas 734719 Jul 23 21:40 fitting

atp gravatar image atp  ( 2013-07-24 04:47:55 -0600 )edit

I just redid the installation to /opt/ros/groovy according to: And I get the same error again.

atp gravatar image atp  ( 2013-07-24 08:19:55 -0600 )edit

You might want to put this information back in the original question, rather than a really long comment chain =) (I'd include the information about the exact original invocation of rosrun, full paths to all files, your path/what you're sourcing, and the steps you followed to set up your catkin_ws)

lindzey gravatar image lindzey  ( 2013-07-24 08:25:43 -0600 )edit

answered 2013-07-23 21:46:23 -0600

Lucile gravatar image

updated 2013-07-23 21:46:43 -0600

Are you trying to use a python file ? And if so, did you enable its execution ? If not using a python file, are you compiled your C++ code using catkin_make at the catkin's workspace root ?

edit flag offensive delete link more


No python. I compiled using catkin_make from /home/andreas/catkin_ws which should be the catkin's workspace root. I also sourced catkin_ws/devel/setup.bash

atp gravatar image atp  ( 2013-07-24 02:31:53 -0600 )edit

Question Tools



Asked: 2013-07-23 15:27:38 -0600

Seen: 2,512 times

Last updated: Jul 24 '13