Ask Your Question
1

Jenkins Build Issues - File INSTALL cannot find /obj-x86_64-linux-gnu

asked 2013-07-23 03:50:49 -0500

allenh1 gravatar image

updated 2013-07-23 05:58:03 -0500

Still having trouble with building packages... This time, it seems that the issue is almost resolved, however. The build seems successful (as far as I can tell); however, the cmake_install.cmake file causes make to fail. Does anyone see the issue?

Install the project...
/usr/bin/cmake -P cmake_install.cmake
-- Install configuration: ""
-- Installing: /tmp/buildd/ros-hydro-p2os-teleop-1.0.1-0raring-20130723-0625/debian/ros-hydro-p2os-teleop/opt/ros/hydro/share/p2os_teleop/cmake/p2os_teleop-msg-paths.cmake
CMake Error at cmake_install.cmake:40 (FILE):
  file INSTALL cannot find
  "/tmp/buildd/ros-hydro-p2os-teleop-1.0.1-0raring-20130723-0625/obj-x86_64-linux-gnu/devel/include/p2os_teleop".


make[1]: *** [install] Error 1
make[1]: Leaving directory `/tmp/buildd/ros-hydro-p2os-teleop-1.0.1-0raring-20130723-0625/obj-x86_64-linux-gnu'
dh_auto_install: make -j1 install DESTDIR=/tmp/buildd/ros-hydro-p2os-teleop-1.0.1-0raring-20130723-0625/debian/ros-hydro-p2os-teleop AM_UPDATE_INFO_DIR=no returned exit code 2
make: *** [binary] Error 29
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
E: Failed autobuilding of package
W: no hooks of type C found -- ignoring
I: unmounting /var/cache/pbuilder/ccache filesystem
I: unmounting dev/pts filesystem
I: unmounting proc filesystem
I: cleaning the build env 
I: removing directory /var/cache/pbuilder/build//19152 and its subdirectories
Process leaked file descriptors. See <a href="http://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build">http://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build</a> for more information
Build step 'Execute shell' marked build as failure
Build step 'Groovy Postbuild' marked build as failure
Build step 'Groovy Postbuild' marked build as failure
Description set:

Update: So I think I got it. The CMakeLists.txt file had some unnecessary stuff that made this a problem.

edit retag flag offensive close merge delete

Comments

Weird, can you post an answer and accept for others who run into this?

William gravatar imageWilliam ( 2013-07-23 10:28:03 -0500 )edit

Sorry to be unclear... It's still not working.

allenh1 gravatar imageallenh1 ( 2013-07-23 10:29:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-07-23 10:50:03 -0500

William gravatar image

updated 2013-09-14 22:30:00 -0500

Evgeny gravatar image

I am looking at your repository and packages here:

https://github.com/allenh1/p2os/tree/master/p2os_teleop

A few things:

  • remove all mainpage.dox (this is for rosbuild only)
  • remove all manifest.xml (this is for rosbuild only)
  • remove all instances of these lines: (this was a hold over from rosbuild and should not be used anymore)

Example below.

# set the default path for built executables to the "bin" directory
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin)
# set the default path for built libraries to the "lib" directory
set(LIBRARY_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/lib)

Specifically for p2os_teleop, you call generate_messages but never declare any messages, you should remove that macro call. I think that will fix the above issue. I opened a ticket to get a better error message here:

https://github.com/ros/genmsg/issues/31

edit flag offensive delete link more

Comments

Thank you much!!! Worked like a charm.

allenh1 gravatar imageallenh1 ( 2013-07-23 15:11:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-23 03:50:49 -0500

Seen: 771 times

Last updated: Sep 14 '13