Ask Your Question
0

Jenkins debian building fails: rosdep claims that roscpp is not a system dependency

asked 2013-02-06 05:40:55 -0600

dejanpan gravatar image

Hi there, I am trying to release this following dry stack into ROS Groovy: http://svn.code.sf.net/p/bosch-ros-pkg/code/trunk/stacks/bosch_common/.

The build failed emails that I got from Jenkins state that " Error: package/stack 'rtc' depends on non-existent package 'roscpp' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update'" (http://jenkins.willowgarage.com:8080/job/ros-groovy-bosch-common_binarydeb_oneiric_amd64/1/console). I had the same error in the pre-release but I sloppily ignored it.

I agree that roscpp is not a system dependency but I also do not declare it as such. Any suggestions what might have gone wrong?

D.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-02-11 19:19:08 -0600

tfoote gravatar image

The issue you are having is that you are missing ros_comm in your stack dependencies. Which means that roscpp is not pulled in when satisfying installation dependencies. Thus neither rospack nor rosdep can find roscpp when processing the package.

edit flag offensive delete link more

Comments

Maybe this is a better fix. What also fixed it was to remove roscpp all together, it seems that there was no explicit dependencies on it.

dejanpan gravatar imagedejanpan ( 2013-02-18 02:07:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-06 05:40:55 -0600

Seen: 598 times

Last updated: Feb 11 '13