Ask Your Question
0

Debian support for libaria

asked 2013-07-10 21:51:24 -0500

wombat_sdu gravatar image

updated 2014-01-28 17:17:12 -0500

ngrennan gravatar image

I have groovy installed on a raspberry pi running raspbian and am currently tying to install ROSARIA. However when running 'rosdep install ROSARIA' (following the instructions here: ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA) I keep running into this error:

ROSARIA: No definition of [libaria] for OS [debian]

This isn't due to rosdep dependancies being missing for debian in general as I have already solved that, but looking at the base.yaml file there appears to only be support for libaria for ubuntu:

libaria: ubuntu: source: alternate-uri: 'http://aus-www.rasip.fer.hr/libaria.rdmanifest' md5sum: f00cf4b5496b085a6b8ef9ce0389ec0b uri: 'http://amor-ros-pkg.googlecode.com/files/libaria.rdmanifest'

How can I update this successfully for debian support? I tried just changing ubuntu for debian in the above text in the base.yaml file, and no longer got the "No definition of [libaria] for OS [debian]" but when performing "rosdep install ROSARIA" I start getting errors such as:

strip: Unable to recognise the format of the input file `/usr/local/Aria/ArNetworking/examples/clientDemo'

I have recompiled the files that cause this error many times (I downloaded the source code for Aria from the mobilerobots website for 32-bit machines and recompiled everything) so they are built for my system, so these errors make me think that my ubuntu to debian fix is the cause.

If anyone has any insight into this problem it would be greatly appreciated. Thanks.

EDIT:

I have rebuilt the binaries many times. When I first tried to install Aria I got similar strip errors and deleted the binaries and rebuilt them and now running 'make install' inside the Aria directory itself leads to a successful compilation so I'm guessing all the files are compiled correctly now. However with after the base.yaml file I'm getting these strip errors when running rosdep install ROSARIA. The binary for the above 'clientDemo' has definitely been rebuild (I just did it again), yet I got the same errors again when running 'rodep install ROSARIA'.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-10 22:09:44 -0500

po1 gravatar image

This error is likely to happen if the lib you are trying to use is shipped with pre-built binaries. Remember that binaries built on a PC cannot run on the RPi, which has an ARM processor with a different instruction set. If that is the case, it has nothing to do with the fact that you are running debian instead of ubuntu.

If you can find the entire source code for this lib, then you should be able to compile every last bit of it on the RPi (or on a qemu chroot), and install it normally. Otherwise, you are stuck with using a PC for any node using this lib, or not using the lib at all.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-10 21:51:24 -0500

Seen: 413 times

Last updated: Jul 11 '13