Ask Your Question
1

Cannot Find COLLADA Headers [closed]

asked 2013-07-03 07:07:01 -0500

teddybouch gravatar image

updated 2013-07-03 07:18:36 -0500

I'm trying to install ROS Groovy on a Lenovo X200 Tablet with openSUSE 12.3. I've installed COLLADA-DOM 2.4, and it installed its headers to /usr/local/include/collada-dom2.4/. I have double and triple-checked, and dae.h is in that folder. However, when I try to run the full desktop install with:

sudo ./src/catkin/bin/catkin_make_isolated --install-space /opt/ros/groovy --install -DSETUPTOOLS_DEB_LAYOUT=OFF

I get the following error:

    [100%] Building CXX object CMakeFiles/collada_parser.dir/src/collada_parser.cpp.o
/home/abouchard/ros_catkin_ws/src/collada_parser/src/collada_parser.cpp:45:17: fatal error: dae.h: No such file or directory
compilation terminated.
make[2]: *** [CMakeFiles/collada_parser.dir/src/collada_parser.cpp.o] Error 1
make[1]: *** [CMakeFiles/collada_parser.dir/all] Error 2
make: *** [all] Error 2
Traceback (most recent call last):
  File "./src/catkin/bin/../python/catkin/builder.py", line 717, in build_workspace_isolated
    number=index + 1, of=len(ordered_packages)
  File "./src/catkin/bin/../python/catkin/builder.py", line 497, in build_package
    install, force_cmake, quiet, last_env, cmake_args, make_args + catkin_make_args
  File "./src/catkin/bin/../python/catkin/builder.py", line 353, in build_catkin_package
    run_command(make_cmd, build_dir, quiet)
  File "./src/catkin/bin/../python/catkin/builder.py", line 198, in run_command
    raise subprocess.CalledProcessError(proc.returncode, ' '.join(cmd))
CalledProcessError: Command '/opt/ros/groovy/env.sh make -j2 -l2' returned non-zero exit status 2
<== Failed to process package 'collada_parser': 
  Command '/opt/ros/groovy/env.sh make -j2 -l2' returned non-zero exit status 2

Reproduce this error by running:
==> /opt/ros/groovy/env.sh make -j2 -l2

Command failed, exiting.

I was thinking that perhaps this was related to the cmake command, and indeed there is no FindCOLLADA_DOM.cmake file on the computer, but I found one online and put it in /usr/share/cmake/Modules to no avail. I'm still digging into the cmake documentation to see if I can find any error either in the CMakeLists for collada_parser in ROS or the FindCOLLADA_DOM.cmake script, but I don't seem to be making any headway.

Has anyone else run into this that could perhaps give me some pointers?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by teddybouch
close date 2013-07-10 05:59:51

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-05 04:57:05 -0500

teddybouch gravatar image

Chalk this one up to a mystery - I uninstalled everything collada from my system, tried again, and it seems to have worked. Go figure.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-07-03 07:07:01 -0500

Seen: 824 times

Last updated: Jul 03 '13