Ask Your Question
0

Adding dependencies without rosdep

asked 2013-01-29 03:43:49 -0500

BigBlueDart gravatar image

updated 2013-01-29 04:20:19 -0500

joq gravatar image

I do not have root access on a system that I am trying to install ROS on. I've had some success so far using a python virtualenv, but that has not allowed me to run rosdep. Currently, my catkin build stops while building roslib, saying "Project 'roslib' tried to find library 'tinyxml'". I tried installing tinyxml on my own and manually adding it to my LD_LIBRARY_PATH, but that does not seem to work. Any tips?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-05 08:55:26 -0500

WilliamWoodall gravatar image

You need to add tinyxml to your PKG_CONFIG_PATH, because tinyxml is found using pkg-config. You'll know that your environment is setup correctly when you can run pkg-config --libs tinyxml and get reasonable output.

edit flag offensive delete link more

Comments

I tried this, but when running the pkg-config command it tells me it can't find the library and that it is looking for a tinyxml.pc file. When I built tinyxml it made no such file. Any tips on that?

BigBlueDart gravatar image BigBlueDart  ( 2013-02-06 10:08:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-29 03:43:49 -0500

Seen: 249 times

Last updated: Feb 05 '13