Ask Your Question
0

Turtlebot Laser Scan Error

asked 2013-06-28 08:08:58 -0500

req09 gravatar image

updated 2016-10-24 08:35:13 -0500

ngrennan gravatar image

I have a turtlebot 1 (create base) with groovy installed and ubuntu precise (12.04 LTS) on both the laptop and the workstation. After following through the tutorial I got stuck on the 3-d visualization portion. I am using a kinect camera and when I ran

roslaunch turtlebot_rviz_launchers view_robot.launch

The rviz program allows me to see the camera data correctly so I know the kinect is powered up. However the laser data gave me an error.

For frame [/camera_depth_frame]: No transform to fixed frame [/base_footprint]. TF error: [Lookup would require extrapolation into the future. Requested time 1372440640.091899911 but the latest data is at time 1372440636.899976015, when looking up transform from frame [/camera_depth_frame] to frame [/base_footprint]]

This was under the Transform [sender=/camera/camera_nodelet_manager]. Which was under status. I got Topic as ok and point as blank. The weird thing was the laser scan was working the run before and I was getting points being received but I couldn't get them to display anywhere.

I want to confirm the laser data was being read because when I ran the calibration I was getting Please find wall error. Reading around the site it seem that the issue may come from the laser data not working.

I also encountered this from time to time

Unhandled exception in thread started by sys.excepthook is missing lost sys.stderr

when running rviz, which would force close it either when I start up rviz and when I try to view the image from the camera. But it seem to fix itself when I close the terminal and rerun it.

The tutorial I used was: http://ros.org/wiki/turtlebot_bringup/Tutorials/groovy/3D%20Visualisation http://ros.org/wiki/turtlebot_bringup/Tutorials/groovy/TurtleBot%20Bringup -> To change the laptop and workstation to the create base. http://ros.org/wiki/turtlebot_calibration/Tutorials/Calibrate%20Odometry%20and%20Gyro ->Stuck at step 3

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-12 10:53:33 -0500

tfoote gravatar image

The TurtleBot simulates laser data from the Kinect data. To get laser data out you need to have the depth clouds coming in and then depthimage_to_laserscan running to generate the laser scan. This does not run by default, but is turned on when youdo calibration and by the follower. If you want to do a different demo or application make sure to include the launch file which turns on the depth camera and does the laser conversions.

edit flag offensive delete link more
0

answered 2013-06-28 12:00:15 -0500

Gazer gravatar image

So, two things: 1) is the laser being publish? Make sure the topic is subscribed; you could set the decay time in Rviz to something like 10 second to see if the laserscan match.

2) is the TF tree working properly? would you like to give some info about your tf setup?

3) it might be the problem of frequency publish by the tf tree. But this is very unlikely in your case.

you could use the command

view_frames

to check the tf tree.

edit flag offensive delete link more

Comments

Sorry for the late response, i changed the decay time to 10 seconds in rviz and no results and i took screen shots of the rviz window with tf tree and laser scan http://imageshack.us/g/1/10223651/ is the link to the album with the pictures

req09 gravatar imagereq09 ( 2013-07-03 07:25:39 -0500 )edit

The follower demo in the tutorial works, I can see the lasers coming out of the kinetic camera so the camera looks like it works, the robot was also able to measure the distance between itself and the person. However during any other operation, like calibration and rviz, the laser scan isn't on.

req09 gravatar imagereq09 ( 2013-07-18 05:53:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-28 08:08:58 -0500

Seen: 1,503 times

Last updated: Aug 12 '13