Is object_recognition_ros supposed to work in Fuerte? [closed]

asked 2013-06-26 14:32:21 -0500

mz gravatar image

updated 2014-01-28 17:17:03 -0500

ngrennan gravatar image

Two questions.

I've been trying for 2 days to get object_recognition_ros to work in Fuerte, and I've come to the conclusion that it's not supposed to work in Fuerte. I need a confirmation. Does it only work in Groovy?

It's specifically for the object_recognition_ros package. I got object_recognition_core to run capture, training, and detection fine, but I need to test detection using bag files, and the BagReader is within object_recognition_ros. In addition, when I run detection using the command for ROS actionlib server according to the instructions on wg-perception.github.io/object_recognition_core/detection/detection.html#detection , they point to the same failure in object_recognition_ros publisher.py - I fixed that, that was 2 days ago, the question is not about this error.

I noticed that object_recognition_ros is not built. Nothing is generated for it in the build/ directory, while things are generated for all other packages, like object_recognition_core, object_recognition_msgs, linemod, tod, etc.

So I wrote a different CMakeLists.txt for object_recognition_ros and wrestled with other cmake things, now cmake generates files for object_recognition_ros, but make gives me errors. I was able to get rid of some of the header file errors by adding include_directory() in the CMakeLists.txt, but a few other header files are non-existent in Fuerte (I found them online only in Groovy documentation):

For info_cache:

object_recognition/src/object_recognition_ros/src/info_cache/info_cache.cpp:170:18: error: ‘createMeshFromBinary’ is not a member of ‘shapes’
For rviz_plugin:
object_recognition/src/object_recognition_ros/src/rviz_plugin/ork_display.cpp:41:44: fatal error: rviz/properties/color_property.h: No such file or directory
**Is there a way to get this to happen in Fuerte - by pulling the Groovy files, or does ORK no longer support Fuerte?** **My second attempt** was to install the binaries with sudo apt-get install ros-fuerte-object-recognition-ros. **One of these two attempts worked partially**, I don't know which one. Now this guy runs:
$ rosrun object_recognition_core detection -c tod_detection_bag.ork --visualize

(where the .ork file is same as the one in tod/conf/detection.ork, with source1 replaced by the BagReader source_1 from here: wg-perception.github.io/object_recognition_core/detection/detection.html#detection )

But it immediately gives me "End of bag.":

[ INFO] [1372288448.168012840]: Initialized ROS. node_name: /object_recognition_server
End of bag.

Given that I still didn't fully generate all (SOME were generated) the files from object_recognition_ros, that might be the problem. So I am really wondering how I can get the cmake stuff above to compile, or get a confirmation that it's not supposed to work in Fuerte; or, everything is normal and "End of bag" is caused by something else?

Second question, detection flag --visualize doesn't bring up any graphics for tod, is this normal? Does tod just not have any visualization, or do I need to install openni-dev from source? (Currently cmake says it can't find openni-dev and visualizations related to openni will be disabled, even though I did install openni from binaries and have it in rospack find.)

Thank you so much!

Update: I ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-06-07 20:25:36.207941

Comments

I ended up skipping the compilations for those 3 modules. That got OR_ros compiled, but it wasn't very useful, since I still don't have a way to work with bag files. I've been using ORK with a real Kinect and adding rosmsg code myself. It'd still be nice if anyone knows how to get bag files to work.

mz gravatar imagemz ( 2013-07-22 11:22:41 -0500 )edit