Ask Your Question
5

Object recognition capture unable to find Pose

asked 2013-09-10 04:44:42 -0500

Jbot gravatar image

updated 2014-01-28 17:17:54 -0500

ngrennan gravatar image

I have an Ubuntu 12.10 with ROS groovy configuration. I use a kinect on a USB2.0 port.

I would like to use the object_recognition package but I don't succeed in make the capture tool work. I succeed capturing my textured_plane but impossible to have a 3D position displayed when I track the features.

Here is my command line for capturing my textured plane :

rosrun object_recognition_capture orb_template -o my_textured_plane --res sxga --fps 15

But when I try to see the position tracking, no position is outputed in the video

rosrun object_recognition_capture orb_track --track_directory my_textured_plane --res sxga --fps 15

But, if I show the matches, the features detection seems to work quite well. image description

So I try some different parameters (more feature points, less threshold ...) but the position never appears.

Does anyone have a clue on why the 3D position is not display while the features are correctly detected?

PS : I also try rosrun object_recognition_capture capture -i my_textured_plane --seg_z_min 0.01 -o silk.bag --preview --res sxga --fps 15 but no object is detected.

edit retag flag offensive close merge delete

Comments

Same problem here. (Ubuntu 13.04 ROS Hydro)

keavenM gravatar imagekeavenM ( 2013-09-19 14:17:59 -0500 )edit

Same problem (Ubuntu12.04 ROS groovy)

averybigant gravatar imageaverybigant ( 2013-09-19 15:29:20 -0500 )edit

hey guys, you can find further information on https://github.com/wg-perception/object_recognition_core/issues/17

averybigant gravatar imageaverybigant ( 2013-09-24 01:53:10 -0500 )edit

Thanks, I will mail him to see if I can help

Jbot gravatar imageJbot ( 2013-09-24 21:33:44 -0500 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2013-09-27 02:58:53 -0500

fivef gravatar image

Have you ever tried:

rosrun object_recognition_capture capture --seg_z_min 0.01 -o silk.bag --preview --res sxga --fps 15

Omitting the -i parameter sets the capture app to use the printed markers. This works for me!

Remark: The orb_template step is not needed if you omit -i.

It seems that there is a bug in orb_template or in capture when matching the features to the template's.

edit flag offensive delete link more

Comments

Wow, it works for me! Thank you for your solution.

averybigant gravatar imageaverybigant ( 2013-09-27 04:26:56 -0500 )edit

I will try this tonight but I wanted to use my own textured plane.

Jbot gravatar imageJbot ( 2013-09-29 22:42:22 -0500 )edit

After a try, it seems that it works wih the standard template. I have upvote your answer but there is still a bug when using our own textured plane.

Jbot gravatar imageJbot ( 2013-09-30 23:46:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2013-09-10 04:44:42 -0500

Seen: 732 times

Last updated: Sep 27 '13