ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Could not find Qt4

asked 2013-06-16 15:18:49 -0500

Hiro gravatar image

updated 2013-11-14 11:07:03 -0500

tfoote gravatar image

I was installing ROS-fuerte on Fedora 17 (64bit) when I encountered this issue. The error message says that it cannot find Qt4, though I did install it. Please help.


-- +++ ros_tutorials
-- Building stack ros_tutorials
-- rospy_tutorials: 2 messages
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   thread
-- roscpp_tutorials: 0 messages
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  QT_UIC_EXECUTABLE) (found suitable version "4.8.4", required is "4.6")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindQt4.cmake:1200 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  ros_tutorials/turtlesim/CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!
edit retag flag offensive close merge delete


Just to make sure; you are following an instruction that's specifically designated for 17(&16) right?

130s gravatar image 130s  ( 2013-06-17 14:20:47 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2013-06-16 17:07:07 -0500

130s gravatar image

updated 2013-06-18 09:49:46 -0500

With the given error message, the issue doesn't seem to be rooted in ROS itself; instead I suspect that it's more about how Qt is installed.

Some links tell that you need to check (and add if necessary) if Qt is in environment variable:


Update 6/17/2013) Not yet sure the solution/workaround but the cause of the bizarre error might be that ros_tutorials/turtlesim/CMakeLists.txt:7 asks for Qt 4.6.

edit flag offensive delete link more

answered 2013-06-17 11:30:41 -0500

tfoote gravatar image

It looks like something is asking for Qt 4.6 but you have 4.8.4 You will need to find what's asking for 4.6 specifically and see if it's possible to upgrade. Fedora is probably ahead of the Ubuntu version.

Note: those names are not environment variables.

edit flag offensive delete link more


Thank you very much for your reply. I followed Issac's off-line suggestion to edit ros_tutorials/turtlesim/CMakeLists.txt to specify version 4.8, but I still got the same error.

Hiro gravatar image Hiro  ( 2013-06-18 17:33:23 -0500 )edit

So I deleted ros_tutorials/turtlesim (this is another suggestion by Issac) and the cmake worked. I am currently getting stuck at "make install" due to a permission error saying that:

Hiro gravatar image Hiro  ( 2013-06-18 17:35:44 -0500 )edit

...that "error: could not create 'build': Permission denied CMake Error at catkin/CMakeFiles/safe_execute_install.cmake:5 (message): Error executing process with arguments Call Stack (most recent call first): catkin/cmake_install.cmake:183 (INCLUDE) cmake_install.cmake:37 (INCLUDE)

Hiro gravatar image Hiro  ( 2013-06-18 17:36:32 -0500 )edit

Probably this is just a local issue, but I don't know why I get this error even though I sudo to run make.

Hiro gravatar image Hiro  ( 2013-06-18 17:37:44 -0500 )edit

You should never sudo make. If you do it once you will always have to do it, and you then don't have any protection from accidental things.

tfoote gravatar image tfoote  ( 2013-06-18 17:51:16 -0500 )edit

answered 2013-06-17 07:46:22 -0500

Hiro gravatar image

Thank you very much for your prompt response. I tried the suggestions on the links that you provided, but it does not still work. I made sure that qt is properly installed, and manually set the environment variables (QT_MOC_EXECUTABLE QT_RCC_EXECUTABLE QT_UIC_EXECUTABLE), but still see the same error saying that those are missing. It would be very appreciated if you have any idea about how to get around.



edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-06-16 15:18:49 -0500

Seen: 4,065 times

Last updated: Jun 18 '13