Ask Your Question
0

Help troubleshooting TurtleBot arm interactive markers

asked 2013-06-11 20:57:28 -0500

Hi All,

I can't expect anyone to hold the golden key here, but I hope people can suggest what I might do to figure out where the error is.

Previously Ubuntu 11.10 and Electric was working. Currently using Ubuntu 12.04 with Fuerte... not working yet. I can use the arm's interactive markers in the "joint mode", but the "trajectory mode" gives errors.

It appears code in ROS is outdated, so I am using the arbotix code from svn checkout http://vanadium-ros-pkg.googlecode.com/svn/trunk/ vanadium-ros-pkg-read-only and arm code from git clone -b fuerte-devel https://github.com/turtlebot/turtlebot_arm.git. Both were ok on electric.

When I try moving the gripper, here are the messages I get from the marker server...

roslaunch turtlebot_arm_interactive_markers arm_markers.launch
...
core service [/rosout] found
process[turtlebot_arm_marker_server-1]: started with pid [4157]
[ INFO] [1371014595.011226032]: [turtlebot arm marker server] Initialized.
[ INFO] [1371014771.673044255]: Finished in state [ABORTED]
[ INFO] [1371014849.828211285]: Finished in state [ABORTED]

Also, I get some weird output from the arm server (there's an error val at bottom, and appears to have no plan)...

core service [/rosout] found
process[environment_server-1]: started with pid [3306]
process[planning_scene_validity_server-2]: started with pid [3307]
process[arm_kinematics-3]: started with pid [3309]
process[simple_arm_server-4]: started with pid [3314]
process[reset_arm_server-5]: started with pid [3368]
process[relax_arm_server-6]: started with pid [3376]
[ INFO] [1371014531.525485648]: Environment server started
[ INFO] [1371014532.206517619]: Successfully connected to planning scene action server for /planning_scene_validity_server
[ INFO] [1371014532.413203478]: Successfully connected to planning scene action server for /arm_kinematics
[INFO] [WallTime: 1371014533.593215] simple_arm_server node started
[INFO] [WallTime: 1371014771.458778] Parsing move to:
header: 
  seq: 0
  stamp: 
    secs: 0
    nsecs: 0
  frame_id: arm_base_link
pose: 
  position: 
    x: 0.00575924804434
    y: -8.69042996783e-05
    z: 0.384833902121
  orientation: 
    x: -0.00553457715202
    y: -0.721403773506
    z: -0.00530987136779
    w: 0.692472215538
roll 0
solution: 
  joint_state: 
    header: 
  seq: 0
  stamp: 
    secs: 0
    nsecs: 0
  frame_id: ''
    name: []
    position: []
    velocity: []
    effort: []
  multi_dof_joint_state: 
    stamp: 
      secs: 0
      nsecs: 0
    joint_names: []
    frame_ids: []
    child_frame_ids: []
    poses: []
error_code: 
  val: -27

Here are all the nodes/commands I run

roslaunch turtlebot_bringup minimal_arm.launch
rosrun turtlebot_dashboard turtlebot_dashboard, set full mode, enable breaker
roslaunch turtlebot_arm_bringup arm.launch
roslaunch turtlebot_arm_bringup simple_arm_server.launch 
rosrun turtlebot_interactive_markers turtlebot_marker_server
roslaunch turtlebot_arm_interactive_markers arm_markers.launch
rosrun rviz rviz

THANK YOU!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-06-12 00:32:18 -0500

fergs gravatar image

So, the -27 for error_code, can be decoded by looking at the message for arm_navigation: http://ros.org/doc/api/arm_navigation_msgs/html/msg/ArmNavigationErrorCodes.html

-27 apparently == FRAME_TRANSFORM_FAILURE

Which I presume means you have some sort of TF problem.

Is your turtlebot arm on a turtlebot? After electric, with the release of turtlebot 2, much (if not all) of turtlebot core stacks got completely ripped up and changed -- and so something in the URDF might not be properly connected, or some joint state may not be published.

In addition, with the move to MoveIt, arm_navigation is really no longer maintained or developed (and MoveIt was not really ready for users until Groovy). Unfortunately, this combo leaves the Fuerte turtlebot_arm a bit of a mess.

I've recently started to move the turtlebot_arm to Groovy/MoveIt, with a custom ikfast plugin to replace my hacky old simple_arm_server. Unfortunately it is just a side project, and so progress has been intermittent.

edit flag offensive delete link more

Comments

Thank you @fergs for checking. It's on a Turtlebot, and RViz didn't report TF errors. I will set up an arm only URDF for testing. If that doesn't work, I'm assuming it would be a change to the ros-fuerte-simple-arms stack, since the arbotix and turtlebot_arm code are the same (AFAIK). Thanks!

dougbot01 gravatar image dougbot01  ( 2013-06-12 08:19:53 -0500 )edit

l don't recall there being any real updates to simple_arms in Fuerte (I was very late to adopt Fuerte, trying to stay on stable Electric for quite some time, and then jumped to Groovy pretty quickly).

fergs gravatar image fergs  ( 2013-06-12 18:03:35 -0500 )edit

I tried an arm only URDF, with the top plate as the base_link (otherwise it was throwing some errors for multi-dof joints?). Even with that, still no luck... same errors as before. I would love to figure it out, but for now I will have to go back to 11.10/Electric. Thanks for the feedback @fergs !!

dougbot01 gravatar image dougbot01  ( 2013-06-12 21:13:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-11 20:57:28 -0500

Seen: 280 times

Last updated: Jun 12 '13