Ask Your Question

What python version does Catkin require?

asked 2013-06-11 20:20:20 -0600

130s gravatar image

updated 2014-01-28 17:16:51 -0600

ngrennan gravatar image

I have a non-debian OS (QNX 6.5) where default Python version is 2.5. What version of python is required to get catkin run (meanwhile I try to upgrade the python's version and port catkin for it)?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-06-11 20:21:50 -0600

William gravatar image

catkin requires python 2.7, which is the minimum version set out in REP 3:

It _might_ work with python 2.6, but I couldn't promise this.

edit flag offensive delete link more


Has it been tested with Python 3.2 or 3.3?

joq gravatar image joq  ( 2013-06-12 02:54:21 -0600 )edit

It is not regularly tested on Python 3.2 or 3.3. Parts are tested (catkin_pkg) regularly: is known to be failing on 3.3

William gravatar image William  ( 2013-06-12 07:16:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-06-11 20:20:20 -0600

Seen: 1,635 times

Last updated: Jun 11 '13