ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Navigation stack, rosparam error! [help!]

asked 2013-06-09 09:17:36 -0500

Gazer gravatar image

updated 2013-06-09 13:44:15 -0500

Hi all!

I have set up the navigation stack. And after running:

roslaunch navigation_for_segbot move_base.launch

I receive the following error msg:

error loading <rosparam> tag: 

    file does not exist [/home/abc/fuerte_workspace/sandbox/navigation_for_segbot/params/costmap_common_params.yaml]
XML is <rosparam command="load" file="$(find navigation_for_segbot)/params/costmap_common_params.yaml" ns="global_costmap"/>

Here is my roslaunch file:

  <master auto="start"/>

  <!-- Run the map server -->
  <node name="map_server" pkg="map_server" type="map_server" args="$(find navigation_for_segbot)/maps/bwi_test_world.yaml"/>

  <!--- Run AMCL -->
  <include file="$(find amcl)/examples/amcl_omni.launch" />

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find navigation_for_segbot)/params/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find navigation_for_segbot)/params/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find navigation_for_segbot)/params/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find navigation_for_segbot)/params/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find navigation_for_segbot)/params/base_local_planner_params.yaml" command="load" />

And I have do have my


inside my params folder inside the packge.

edit retag flag offensive close merge delete


Are you 100% sure that the file /home/abc/fuerte_workspace/sandbox/navigation_for_segbot/params/costmap_common_params.yaml exists, that it's readable by your user and that it contains some yaml code?

Martin Günther gravatar image Martin Günther  ( 2013-06-10 01:16:31 -0500 )edit

did u solve this??? that thing is happening to me....

salime gravatar image salime  ( 2013-08-01 13:42:54 -0500 )edit

The error says exactly what the problem is. The file does not exist.

Martin Günther gravatar image Martin Günther  ( 2013-08-02 00:06:08 -0500 )edit

I have that file, I am completely sure, and the code is readable because it was in the tutorial, so I don't know what else could it be

salime gravatar image salime  ( 2013-08-02 05:45:45 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-03-27 20:30:15 -0500

sai gravatar image


I experienced the same error with a different package. I could open the file and its in the right location too.

The solution is just delete the file and create it once again and put the data in it. It worked for me!

edit flag offensive delete link more

Question Tools


Asked: 2013-06-09 09:17:36 -0500

Seen: 1,283 times

Last updated: Mar 27 '14