ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

microstrain_3dmgx2_imu rosmake fail

asked 2013-06-04 19:51:20 -0500

Zoken gravatar image

I am following tutorial from microstrain_3dmgx2_imu/Tutorials/UsingTheIMUNode

Trying to get my 3DM-GX3-25 to work

When i rosdep install microstrain_3dmgx2_imu everything is fine

when I do rosmake microstrain_3dmgx2_imu I get

[rosmake-4] Starting >>> microstrain_3dmgx2_imu [ make ]
[ rosmake ] All 2 lines {-------------------------------------------------------------------------------

mkdir: cannot create directory `build': Permission denied

[ rosmake ] Output from build of package microstrain_3dmgx2_imu written to: [ rosmake ] /home/J/.ros/rosmake/rosmake_output-20130605-132831/microstrain_3dmgx2_imu/build_output.log [rosmake-4] Finished <<< microstrain_3dmgx2_imu [FAIL] [ 0.06 seconds ]
[ rosmake ] Halting due to failure in package microstrain_3dmgx2_imu. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Results:
[ rosmake ] Built 38 packages with 1 failures.

When i tried to continue to the next step after plugging in the imu and typing ls -l /dev/ttyUSB0

I get ls: cannot access /dev/ttyUSB0: No such file or directory

Is my problem due to rosmake failing or is it the usb port problem or is it both?

I tried rosmake with root and it has no error but the directory is still not found o.O

I refered to the troubleshooting page for microstrain_3dmgx2_imu but my problem is not listed :(

edit retag flag offensive close merge delete

1 Answer

Sort by ┬╗ oldest newest most voted

answered 2013-06-04 20:16:48 -0500

Zoken gravatar image

FIXED! i did sudo -s to rosmake microstrain_3dmgx2_imu with no errors then ls -l /dev/ttyACM0 instead of ls -l /dev/ttyUSB0 and everything work miracle

edit flag offensive delete link more

Question Tools


Asked: 2013-06-04 19:51:20 -0500

Seen: 188 times

Last updated: Jun 04 '13