Ask Your Question
0

How to set up IMU_UM6 on UART?

asked 2013-06-04 05:42:39 -0500

TJump gravatar image

I need to connect an IMU_UM6 to a UART port on my BeagleBone. The default location in the imu_um6 node to set the sensor is ttyUSB. How do I set this up for streaming from the UART?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-06-04 06:26:54 -0500

mjcarroll gravatar image

The UART usually enumerates under a device name like /dev/ttyS0 or /dev/ttyS1.

Try changing the port parameter to the hardware UART device name in your launch file.

<launch>
    <node pkg="imu_um6" type="imu_um6_node.py" name="imu_um6_node" output="screen" respawn="true">
        <param name="port" type="string" value="/dev/ttyS0"/>
    </node>
</launch>
edit flag offensive delete link more

Comments

Thanks for the info. With dmesg | grep tty the uart ports "seem" to be at ttyO0 - ttyO5. I have the UM6 attached to uart5 on the Beaglebone but I'm still not getting the imu_um6 node to find the actual sensor.

TJump gravatar imageTJump ( 2013-06-04 09:59:11 -0500 )edit

I'm not sure what you have/haven't done, but it does appear that the UART pins aren't enabled by default in the Angstrom image according to here: http://www.gigamegablog.com/2012/01/22/beaglebone-coding-101-using-the-serial-and-analog-pins/ Perhaps you have to enable the correct pins?

mjcarroll gravatar imagemjcarroll ( 2013-06-04 10:46:08 -0500 )edit

Yep, that was it. Once I set the pin mux it connected to the UM6 just fine.

TJump gravatar imageTJump ( 2013-06-04 13:11:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-04 05:42:39 -0500

Seen: 188 times

Last updated: Jun 04 '13