Ask Your Question
0

Errors while installing ros-groovy on beablebone with ubuntu 12.10

asked 2013-03-18 12:24:08 -0600

b4ll-b0t gravatar image

updated 2013-04-28 23:23:34 -0600

ipso gravatar image

I am trying hard to install ROS groovy from the source on a beaglebone board which has installed the Ubuntu 12.10 by following the the instructions on this page: http:// ros.org/wiki/groovy/Installation/Source

Everything was working well until it got some errors with building the catkin Packages as cited below. I would therefore be grateful to receive some suggestions on how you propose to solve this problem.

Regards, b4llb0t

Partial output of the terminal (the complete terminal output is available at http:// pastebin.com/LbTPaXYU):

$ wstool init src -j8 packages http:// packages.ros.org/web/rosinstall/generate/raw/groovy/ros_comm

....

ERROR [vcstools] Tarball download unpack failed: <urlopen error [Errno -2] Name or service not known>[/vcstools]
ERROR [vcstools] Tarball download unpack failed: <urlopen error [Errno -2] Name or service not known>[/vcstools]
ERROR [vcstools] Tarball download unpack failed: <urlopen error [Errno -2] Name or service not known>[/vcstools]
Exception caught during install: Error processing 'rosconsole' : [rosconsole] Checkout of https:// github.com/ros-gbp/ros_comm-release/archive/release/rosconsole/1.9.41.tar.gz version ros_comm-release-release-rosconsole-1.9.41 into /home/ubuntu/ros_catkin_ws/src/rosconsole failed.
Error processing 'catkin' : [catkin] Checkout of https:// github.com/ros-gbp/catkin-release/archive/release/catkin/0.5.63.tar.gz version catkin-release-release-catkin-0.5.63 into /home/ubuntu/ros_catkin_ws/src/catkin failed.
Error processing 'genmsg' : [genmsg] Checkout of https:// github.com/ros-gbp/genmsg-release/archive/release/genmsg/0.4.17.tar.gz version genmsg-release-release-genmsg-0.4.17 into /home/ubuntu/ros_catkin_ws/src/genmsg failed.
Error processing 'rosbash' : [rosbash] Checkout of https:// github.com/ros-gbp/ros-release/archive/release/rosbash/1.9.42.tar.gz version ros-release-release-rosbash-1.9.42 into /home/ubuntu/ros_catkin_ws/src/rosbash failed.
Error processing 'roslib' : [roslib] Checkout of https:// github.com/ros-gbp/ros-release/archive/release/roslib/1.9.42.tar.gz version ros-release-release-roslib-1.9.42 into /home/ubuntu/ros_catkin_ws/src/roslib failed.
Error processing 'roscreate' : [roscreate] Checkout of https:// github.com/ros-gbp/ros-release/archive/release/roscreate/1.9.42.tar.gz version ros-release-release-roscreate-1.9.42 into /home/ubuntu/ros_catkin_ws/src/roscreate failed.
Error processing 'roslang' : [roslang] Checkout of https:// github.com/ros-gbp/ros-release/archive/release/roslang/1.9.42.tar.gz version ros-release-release-roslang-1.9.42 into /home/ubuntu/ros_catkin_ws/src/roslang failed.
Error processing 'roscpp' : [roscpp] Checkout of https:// github.com/ros-gbp/ros_comm-release/archive/release/roscpp/1.9.41.tar.gz version ros_comm-release-release-roscpp-1.9.41 into /home/ubuntu/ros_catkin_ws/src/roscpp failed.
Error processing 'topic_tools' : [topic_tools] Checkout of https:// github.com/ros-gbp/ros_comm-release/archive/release/topic_tools/1.9.41.tar.gz version ros_comm-release-release-topic_tools-1.9.41 into /home/ubuntu/ros_catkin_ws/src/topic_tools failed.
Error processing 'rostest' : [rostest] Checkout of https:// github.com/ros-gbp/ros_comm-release/archive/release/rostest/1.9.41.tar.gz version ros_comm-release-release-rostest-1.9.41 into /home/ubuntu/ros_catkin_ws/src/rostest failed.
Error processing 'rosbag' : [rosbag] Checkout of https:// github.com/ros-gbp/ros_comm-release/archive/release/rosbag/1.9.41.tar.gz version ros_comm-release-release-rosbag-1.9.41 into /home/ubuntu/ros_catkin_ws/src/rosbag failed.
Error processing 'rosmsg' : [rosmsg] Checkout of https:// github.com/ros-gbp/ros_comm-release/archive/release/rosmsg ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-18 15:39:45 -0600

ahendrix gravatar image

updated 2013-03-19 22:33:50 -0600

From looking at the full output, it looks like most packages downloaded successfully, and a few failed.

Try running with -j1 instead of -j8; I suspect that your system can't handle the load of running 8 simultaneous downloads.

You may also want to consult the ARM Installation and Raspbian Installation instructions, since your system is ARM, and most of the tweaks required to install on Raspberry Pi also apply to other ARM systems.

edit flag offensive delete link more

Comments

I don't think what you suggested before was the main issue since I got the following output with ifconfig and ping http://pastebin.com/iFXHqdXP . In addition, if it helps, the complete terminal output is available at http://pastebin.com/LbTPaXYU

b4ll-b0t gravatar imageb4ll-b0t ( 2013-03-19 20:09:37 -0600 )edit

The complete output is quite helpful; thanks! It looks like your internet connection is working, and only a few packages failed; probably due to high load somewhere.

ahendrix gravatar imageahendrix ( 2013-03-19 22:29:30 -0600 )edit

Thank you very much for the extra information. Apropos, it worked very well with $ wstool init src -j1 packages http:// packages.ros.org/web/rosinstall/generate/raw/groovy/ros_comm

b4ll-b0t gravatar imageb4ll-b0t ( 2013-03-20 20:12:11 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-18 12:24:08 -0600

Seen: 1,639 times

Last updated: Mar 19 '13