Ask Your Question
2

build of ros fuerte colladadom fails on armhf - beaglebone

asked 2013-03-21 14:34:04 -0600

updated 2013-03-21 15:34:14 -0600

tfoote gravatar image

Hi All,

I was following a guide on building ros for an armhf device (beaglebone) however ran into a problem in that my compiler failed when compiling the level 2 packages

The compiler error is:

[rosmake-0] Starting >>> rosconsole [ make ]                                    
[rosmake-0] Finished <<< rosconsole  No Makefile in package rosconsole          
[rosmake-0] Starting >>> ivcon [ make ]                                         
[rosmake-0] Finished <<< ivcon [PASS] [ 9.57 seconds ]                          
[rosmake-0] Starting >>> roslang [ make ]                                       
[rosmake-0] Finished <<< roslang  No Makefile in package roslang                
[rosmake-0] Starting >>> roscpp [ make ]                                        
[rosmake-0] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-0] Starting >>> colladadom [ make ]                                    
[ rosmake ] All 14 linesolladadom: 388.8 sec ]       [ 1 Active 4/102 Complete ]
{-------------------------------------------------------------------------------
  ROOT is: /home/ubuntu/ros/robot_model/colladadom
  mkdir -p /home/ubuntu/ros/robot_model/colladadom/include
  mkdir -p /home/ubuntu/ros/robot_model/colladadom/lib
  making it
  cd build/colladadom/dom && make -l1
  make[1]: Entering directory `/home/ubuntu/ros/robot_model/colladadom/build/colladadom/dom'
  Compiling src/1.5/dom/domTypes.cpp to build/linux-1.5/obj/domTypes.o
  g++: internal compiler error: Killed (program cc1plus)
  Please submit a full bug report,
  with preprocessed source if appropriate.
  See <file:///usr/share/doc/gcc-4.6/README.Bugs> for instructions.
  make[1]: *** [build/linux-1.5/obj/domTypes.o] Error 4
  make[1]: Leaving directory `/home/ubuntu/ros/robot_model/colladadom/build/colladadom/dom'
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package colladadom written to: 4/102 Complete ]
[ rosmake ]    /home/ubuntu/.ros/rosmake/rosmake_output-20130321-191548/colladadom/build_output.log
[rosmake-0] Finished <<< colladadom [FAIL] [ 389.12 seconds ]                   
[ rosmake ] Halting due to failure in package colladadom. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                            
[ rosmake ] Built 5 packages with 1 failures.                                   
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/ubuntu/.ros/rosmake/rosmake_output-20130321-191548

Stackoverflow says the g++: internal compiler error: Killed (program cc1plus) error is due to a lack of memory, which may be correct as the beagle bone has 250Mb, though the original guide did not mention anything on it being a problem.

Can anyone suggest a workaround or how to cross compile ros for armhf?

cheers

Peter

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-03-22 06:02:30 -0600

Claudio gravatar image

I've seen this on other boards: when the compiler has to fetch so many things it runs out of memory, strange error messages are output. To be sure of this just run HTOP or TOP in a terminal and observe the memory.

To get away with the compilation you need to increase your memory: either create or modify a swap file as shown here.

edit flag offensive delete link more

Comments

molto bene claudio! grazie!

PeterMilani gravatar imagePeterMilani ( 2013-03-23 15:44:07 -0600 )edit

Just wanted to say that 3 years later this answer helped me a lot! Thanks +1

spmaniato gravatar imagespmaniato ( 2016-02-16 09:18:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-21 14:34:04 -0600

Seen: 376 times

Last updated: Mar 22 '13