Ask Your Question
0

no ros workspace after rebooting

asked 2013-05-24 11:04:01 -0600

mv gravatar image

updated 2013-05-24 11:16:00 -0600

ros doesn't keep the workspace in "fuerte" after rebooting my computer, I have to keep telling ros where the workspace is after booting the computer. Can anyone help assess what the problem is or how to solve it?

edit retag flag offensive close merge delete

Comments

4

Did you source the setup.bash in the workspace in your .bashrc?

joq gravatar imagejoq ( 2013-05-24 17:14:12 -0600 )edit

I am not sure what you mean, I just followed the tutorial from ros and it says to re-source with: source ~/fuerte_workspace/setup.bash .... was there an extra step I had to do?

mv gravatar imagemv ( 2013-05-28 09:26:49 -0600 )edit

Thank you joq!

mv gravatar imagemv ( 2013-05-28 10:19:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-28 09:53:19 -0600

Bill Smart gravatar image

updated 2013-05-28 23:25:58 -0600

felix k gravatar image

When you run source ~/fuerte_workspace/setup.bash, it only sets things up in the current shell (terminal window). To get things to work every time you start a shell (terminal window), you need to add the line

source ~/fuerte_workspace/setup.bash

to the file .bashrc in your home directory. This file is sourced every time you start an (interactive) shell.

edit flag offensive delete link more

Comments

This is what joq asked in the comment to the question. I'm assuming that your answer was "no".

Bill Smart gravatar imageBill Smart ( 2013-05-28 09:53:57 -0600 )edit

Thanks guys, sorry but I am still new with linux and ros. But thank you so much for the help!

mv gravatar imagemv ( 2013-05-28 10:16:42 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-24 11:04:01 -0600

Seen: 47 times

Last updated: May 28 '13