Ask Your Question

When i want to create workspace it give me an error [closed]

asked 2019-09-18 02:26:22 -0600

oovidiustr gravatar image

updated 2019-09-18 07:03:00 -0600

Hi everyone!

I try to set up my workspace for ROS Lunar, but when i run the comand rosws set ~/fuerte_workspace/sandbox it give me this error: ERROR in config: Command requires a target workspace.

I followed the steps in the tutorial on ROS.ORG site.

After that I tried Catkin instead of rosbuild. The comands i entered are in this order:

  1. mkdir -p ~/catkin_ws/src

  2. cd ~/catkin_ws/

  3. catkin_make

After this point i get the next error:

#### Running command: "cmake /home/ovidiu/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/ovidiu/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/ovidiu/catkin_ws/install -G Unix Makefiles" in "/home/ovidiu/catkin_ws/build"
-- Using CATKIN_DEVEL_PREFIX: /home/ovidiu/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/lunar
-- This workspace overlays: /opt/ros/lunar
-- Using PYTHON_EXECUTABLE: /home/ovidiu/anaconda3/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/ovidiu/catkin_ws/build/test_results
-- Found gmock sources under '/usr/src/gmock': gmock will be built
-- Found gtest sources under '/usr/src/gmock': gtests will be built
-- Using Python nosetests: /home/ovidiu/anaconda3/bin/nosetests
CMake Error at /opt/ros/lunar/share/catkin/cmake/safe_execute_process.cmake:11 (message):
  returned error code No such file or directory
Call Stack (most recent call first):
  /opt/ros/lunar/share/catkin/cmake/catkin_package_xml.cmake:74 (safe_execute_process)
  /opt/ros/lunar/share/catkin/cmake/all.cmake:163 (_catkin_package_xml)
  /opt/ros/lunar/share/catkin/cmake/catkinConfig.cmake:20 (include)
  CMakeLists.txt:52 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/ovidiu/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/ovidiu/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

I also want to mention that i had anaconda3 installed but I uninstalled it.

If someone could help me i would be grateful.


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by oovidiustr
close date 2019-10-07 03:02:00.762320


I try to set up my workspace for ROS Lunar, but when i run the comand

can you clarify why you call your workspace fuerte_sandbox in that case and try to use rosws? Since Groovy we typically use Catkin workspaces and rosws is rarely used.

gvdhoorn gravatar imagegvdhoorn ( 2019-09-18 02:32:15 -0600 )edit

I followed the instruction on the link I mentioned. At point 3 i stuck. I will try with Catkin.

oovidiustr gravatar imageoovidiustr ( 2019-09-18 03:45:22 -0600 )edit

I followed the instruction on the link I mentioned.

The rosbuild option is deprecated and only there for historical/archival reasons. The default is Catkin.

I tried with Catkin but it give me this message:

please update your original question with the error. Comments are too small for that.

Include all commands that you enter that lead up to the error.

Use the edit button/link and append the new information to your current text.

Do not post a new question.

gvdhoorn gravatar imagegvdhoorn ( 2019-09-18 06:31:24 -0600 )edit

Ok. I edited it.

oovidiustr gravatar imageoovidiustr ( 2019-09-18 06:52:49 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-09-18 07:12:48 -0600

gvdhoorn gravatar image

You appear to have Anaconda installed and active:

-- Using PYTHON_EXECUTABLE: /home/ovidiu/anaconda3/bin/python

that is going to cause problems, as the ROS Python packages are not installed in that environment.

Please deactivate Anaconda (ie: remove it from your PATH) and try again.

edit flag offensive delete link more


How can I do that?

oovidiustr gravatar imageoovidiustr ( 2019-09-18 08:37:17 -0600 )edit

Most likely by:

remov[ing] it from your PATH

gvdhoorn gravatar imagegvdhoorn ( 2019-09-18 08:44:34 -0600 )edit

I uninstalled safe anaconda... but the PYTHON_EXECUTABLE path didn't changed.

oovidiustr gravatar imageoovidiustr ( 2019-09-18 09:06:52 -0600 )edit

Delete the build and devel folders in the workspace. The paths are cached in those.

gvdhoorn gravatar imagegvdhoorn ( 2019-09-18 09:07:59 -0600 )edit

Yes. I deleted entire catkin_ws folder and i run again the commands I wrote before.

Thanks a lot!!!!

oovidiustr gravatar imageoovidiustr ( 2019-09-18 09:51:58 -0600 )edit

Could you please mark the question as answered by ticking the checkmark (✓) to the left of the answer if you feel it has been answered? Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2019-09-18 09:55:47 -0600 )edit

Question Tools

1 follower


Asked: 2019-09-18 02:26:22 -0600

Seen: 42 times

Last updated: Sep 18