Ask Your Question
0

[Turtlebot] Turtlebot doesn't walk in a straight line

asked 2013-05-23 21:45:11 -0500

Midnight gravatar image

updated 2013-11-18 19:31:02 -0500

tfoote gravatar image

Hi All,

I was fiddling my turtlebot today and I found something a bit surprising... It doesn't actually go in a straight line!!

I was running the http://ros.org/doc/electric/api/turtlebot_teleop/html/turtlebot__key_8cpp_source.html (.cpp script) from turtlebot_teleop (yep, I made another package and built the script), and turtlebot moves in a arc... Unsure what is happening here and I tried running http://www.ros.org/wiki/turtlebot_calibration/Tutorials/Calibrate%20Odometry%20and%20Gyro (calibration) and guess what, not just it doesn't work but my turtlebot actually goes backwards! lolz

I was trying to find something on the net but apparently no one else has this problem... Any ideas? Is there something wrong with my parameters or is hardware giving me a hard time? Let me know if you need any data/log/code/etc.

Cheers,

Mid

Hardware: turtlebot (the old type)

ROS version: electric

OS: Ubuntu 10.04

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-25 20:48:36 -0500

tfoote gravatar image

It sounds like one of your motors has died. You can try sending commands directly to the base with twists to command the bot to drive straignt, turn in place right and turn in place left. If you need more help describe the behavior when sending different commands, both commanded and observed.

Based on the calibration driving backwards my guess is that your right wheel motor has failed.

Unfortunately, there's no good fix for that. Check to make sure that the wheels aren't bound on hair or other debris. And beyond that you may actually have a bad motor which will require you to go inside the Create and debug. Unfortunately the Creates are known to wear out over time.

edit flag offensive delete link more

Comments

Hey Tully, thanks for the reply. Righto, I did some test and here what I found out:

Twist.linear.x = 1 => Forward and leftwards

Twist.angular.z = 1 => Rotates anti-clockwise while going forward and right

Twist.angular.z = -1 => Rotates clockwise while going back and right (0.o)

Thanks

Midnight gravatar image Midnight  ( 2013-05-26 20:09:32 -0500 )edit

Also, I wasn't able to take the wheel apart, since it doesn't belong to me. But from observation, I don't see any debris at all... Maybe suggest a way to debug, please?

Thanks again!

Midnight gravatar image Midnight  ( 2013-05-26 20:16:08 -0500 )edit

Unfortunately this seems to me to be a hardware problem. There's not much lower level you can go than sending raw twist commands.

tfoote gravatar image tfoote  ( 2013-05-26 20:27:18 -0500 )edit

Got it. I report on.

Thanks a lot =D

Midnight gravatar image Midnight  ( 2013-05-27 12:52:26 -0500 )edit

Does anyone know of a vendor or source for replacement wheel motors? I'm pretty sure I have a failed motor on a kabuki platform, but I have not been able to locate a replacement.

benabruzzo gravatar image benabruzzo  ( 2017-09-10 14:31:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-23 21:45:11 -0500

Seen: 820 times

Last updated: May 25 '13