Hokuyo communication issue on ARM (BeagleBone) [closed]

asked 2013-05-23 09:31:11 -0600

TJump gravatar image

updated 2014-01-28 17:16:37 -0600

ngrennan gravatar image

When I run: $ roslaunch hokuyo_node hokuyo_test.launch

I get the following error:

roslaunch hokuyo_node hokuyo_test.launch
... logging to /home/rkrs/.ros/log/aa4e49d8-c248-11e2-bdff-bc6a299c667c/roslaunch-bbone2-1184.log

Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://bbone2:56486/

SUMMARY
---------

PARAMETERS
  * /hokuyo/calibrate_time
  * /hokuyo/intensity
  * /hokuyo/port
  * /rosdistro
  * /rosversion


NODES
  /
    hokuyo (hokuyo_node/hokuyo_node)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[hokuyo-1]: started with pid [1139]

core service [/rosout] found
process[hokuyo-1]: started with pid [2955]
[ERROR] [1369266308.601881517]: Exception thrown while opening Hokuyo.
timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

I found in the code that this timeout is reached if retval==0.

I've run port config and confirmed it is as the tutorial reports it should be:

$ ls -l /dev/ttyACM0
crw-rw-rw- 1 root dialout 166, 0 May 22 23:48 /dev/ttyACM0

getID also fails to retrieve the Hokuyo ID

$ rosrun hokuyo_node getID /dev/ttyACM0

with the same error returned as above.

This same Hokuyo, USB cable, et. al. works fine when attached to the PC and run under ROS Fuerte. The BeagleBone is running ROS Groovy.

Any ideas what is causing this error?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-07-27 18:09:01.744614

Comments

Do you have more than one /dev/ttyACM* device?

ahendrix gravatar imageahendrix ( 2013-05-31 07:45:51 -0600 )edit

No, just the one.

TJump gravatar imageTJump ( 2013-06-04 05:26:13 -0600 )edit