ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Hector Trajectory path is not flowing smoothly

asked 2013-05-16 00:09:07 -0500

AeroR gravatar image

updated 2014-01-28 17:16:33 -0500

ngrennan gravatar image

I used the hector mapping package in combination with an XV-11 Vacuum Cleaner. Although its laser has a relatively low range and update rate, the created maps turned out to be pretty accurate, and much better than GMapping.

There is one small problem with displaying the trajectory though. The path it creates is correct for most of the time, but sometimes it determines the robot position wrongly, which results in a 'spiky' trajectory path. I attached an image for clarifying what I mean:

Does anyone have an idea where these erroneous positions come from, and how to solve the problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-05-16 20:16:44 -0500

updated 2013-05-18 00:40:45 -0500

Hi, very interesting to see things working so well with the XV-11, thanks for raising awareness of that :)

The fact that the map looks consistent clearly suggests that the internal state of the mapping system does not jump in as shown in your screenshots. It is thus very likely that your tf setup is messed up in some way (the trajectory server uses tf for generating the path displayed). You most likely have both hector_mapping generating a map->base_link transform as well as some other node doing the same (AMCL would be a candidate for example). When the trajectory server queries tf for transform data based on a timer, it more or less randomly gets one or the other, resulting in this jagged path. That at least is the most probable cause I see from looking at what you posted.

edit flag offensive delete link more



Thank you for your answer! I looked at my transformation frames, and found out that both hector_mapping and my rosbag were publishing on the /odom topic. Depending on which source had last published onto the topic, the trajectory was either updated correctly or wrongly.

AeroR gravatar image AeroR  ( 2013-05-21 04:26:16 -0500 )edit

By the way, I solved this by removing all /odom entries from the rosbag file using the method described here:

AeroR gravatar image AeroR  ( 2013-05-21 04:29:19 -0500 )edit

Question Tools


Asked: 2013-05-16 00:09:07 -0500

Seen: 1,597 times

Last updated: May 18 '13