Ask Your Question
1

Kobuki auto-docking error

asked 2013-05-07 05:40:52 -0500

CarolineQ gravatar image

Hi,

I am currently working with a Turtlebot 2 with a Kobuki base, I tried to follow the tutorial http://ros.org/wiki/kobuki/Tutorials/TestingAutomaticDocking

I can start the Kobuki node with no error, but as soon as I start the auto-docking nodelet I get this error :

Warning: class_loader::class_loader_private: SEVERE WARNING!!! A namespace collision has occured with plugin factory for class (null). New factory will OVERWRITE existing one. This situation occurs when libraries containing plugins are directly linked against an executable (the one running right now generating this message). Please separate plugins out into their own library or just dont link against the library and use either class_loader::ClassLoader/MultiLibraryClassLoader to open.
         at line 180 in /opt/ros/groovy/include/class_loader/class_loader_core.h
/opt/ros/groovy/lib/nodelet/nodelet: symbol lookup error: /opt/ros/groovy/lib/libkobuki_auto_docking_ros.so: undefined symbol: _ZN9actionlib15GoalIDGeneratorC1Ev
[kobuki-2] process has died [pid 31630, exit code 127, cmd /opt/ros/groovy/lib/nodelet/nodelet manager __name:=kobuki __log:=/home/caroline/.ros/log/3fd781dc-b72b-11e2-a8e9-002354f2e9ef/kobuki-2.log].
log file: /home/caroline/.ros/log/3fd781dc-b72b-11e2-a8e9-002354f2e9ef/kobuki-2*.log

Did someone experience the same problem ? Or does someone have some idea why I get that ?

Caroline

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-07 13:16:44 -0500

Daniel Stonier gravatar image

The module was missing some links to the actionlib library after it got catkinized. This has been fixed, but of course, takes a while to filter through to the public debs. You can either work from source or from the shadow-fixed debs in the meantime.

For others who've had the same problem, the issue is being tracked here.

edit flag offensive delete link more

Comments

Thanks for your answer, I just updated the package and now it seems to be solved. Thanks.

CarolineQ gravatar image CarolineQ  ( 2013-05-09 22:34:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-07 05:40:52 -0500

Seen: 780 times

Last updated: May 07 '13