Why move_base server depends on global_costmap update_frequency? [closed]

asked 2013-05-02 07:27:44 -0500

jorge gravatar image

updated 2013-05-02 07:29:53 -0500

Hello, This is almost a duplicated question of this old and already answered one:

Can no longer connect to move_base server

But I want to go further that the answer this person found. I tried a crappy way to keep the static map unchanged without freezing move_base action server: set observation_sources to nothing. But move_base still spends CPU time updating the map! So it cannot keep sometimes even a 1 Hz rate. I cannot put a lower rate because if not calls to the action server are served at that slow rate. There's no better way to avoid this? Maybe this deserves an issue. I'm working with hydro-devel code, but the same happens with groovy debs.


edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-06-16 19:28:35.792614


Problem remains on hydro...

jorge gravatar image jorge  ( 2013-07-03 15:40:52 -0500 )edit

Are you using the new layer-centric parameter specification, or are you relying on the old pre-hydro syntax?

David Lu gravatar image David Lu  ( 2013-07-04 13:47:43 -0500 )edit

pre-hydro parametrization. How this relates to the problem I mentioned? It´s in my TODO list make use of the new multi-layer further than just reuse the old stile parameters... I´m curious about

jorge gravatar image jorge  ( 2013-07-25 05:17:17 -0500 )edit