Error during localization with AMCL [closed]

asked 2013-04-29 02:45:11 -0500

camilla gravatar image

updated 2013-04-29 21:08:42 -0500

Hi,

I'm using the navigation stack and the Corobot. If I run the corobot with a velocity of 0.2 m/s everything works fine, but if I change my velocity to 0,4 m/s after some time the robot can't localize itself in the given map.
I think it should be a problem of the amcl node.
I'm using an IMU and a laser.

Here is my amcl.launch file

<launch>
    <!--group ns="corobot/amcl" -->
    <node pkg="amcl" type="amcl" name="amcl" output="screen" >
        <!-- Publish scans from best pose at a max of 10 Hz -->
        <param name="odom_model_type" value="diff"/>
        <param name="odom_alpha5" value="0.1"/>
        <param name="transform_tolerance" value="0.2" />
        <param name="gui_publish_rate" value="10.0"/>
        <param name="laser_max_beams" value="30"/>
        <param name="min_particles" value="200"/>
        <param name="max_particles" value="1000"/>
        <!--param name="min_particles" value="1500"/>
        <param name="max_particles" value="10000"/-->
        <param name="kld_err" value="0.05"/>
        <param name="kld_z" value="0.99"/>
        <!-- with imu -->   
        <param name="odom_alpha1" value="0.3"/>
        <param name="odom_alpha2" value="0.2"/>
        <param name="odom_alpha3" value="0.2"/>
        <param name="odom_alpha4" value="0.1"/>
        <!-- without imu
                <param name="odom_alpha1" value="0.3"/>
        <param name="odom_alpha2" value="0.2"/>
        <param name="odom_alpha3" value="0.2"/>
        <param name="odom_alpha4" value="0.1"/>
        -->

        <param name="laser_z_hit" value="0.5"/>
        <param name="laser_z_short" value="0.05"/>
        <param name="laser_z_max" value="0.05"/>
        <param name="laser_z_rand" value="0.5"/>
        <param name="laser_sigma_hit" value="0.2"/>
        <param name="laser_lambda_short" value="0.1"/>
        <param name="laser_lambda_short" value="0.1"/>
        <param name="laser_model_type" value="likelihood_field"/>
        <!-- <param name="laser_model_type" value="beam"/> -->
        <param name="laser_likelihood_max_dist" value="2.0"/>
        <param name="update_min_d" value="0.2"/>
        <param name="update_min_a" value="0.5"/>
        <param name="odom_frame_id" value="odom"/>
        <param name="resample_interval" value="1"/>
        <param name="transform_tolerance" value="0.1"/>
        <param name="recovery_alpha_slow" value="0.0"/>
        <param name="recovery_alpha_fast" value="0.0"/>
        <param name="use_map_topic" value="true"/>
    </node>
    <!--/group-->
</launch>

Any help?
Thank you in advance

EDIT:

I added a bag file with /scan /tf /map and /odom. In the bag files is recorded an initial localization phase, 2/3 path planning that succeded in reaching the goal a path planning in wich the robot get lost. https://www.dropbox.com/s/n0ldecwckxms0wy/2013-04-29-12-15-11.bag.gz

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-06-24 13:42:26.751326

Comments

Have you tried visualizing the particle cloud in rviz? What happens if amcl loses track of the current location? Why did you change some of the default parameters? Maybe you can record and post a bag file from when the problem is happening.

Ben_S gravatar imageBen_S ( 2013-04-29 04:33:18 -0500 )edit

I changed the alpha parameter when I added the Imu

camilla gravatar imagecamilla ( 2013-04-29 06:19:09 -0500 )edit

Maybe i'm blind, but i cant find the link to your bag file. :)

Ben_S gravatar imageBen_S ( 2013-04-29 09:36:51 -0500 )edit

Oh! you are right...I tried again but it load the file then it didn't show it, I don't know how to add it

camilla gravatar imagecamilla ( 2013-04-29 21:03:31 -0500 )edit
camilla gravatar imagecamilla ( 2013-04-29 21:08:10 -0500 )edit