Ask Your Question
1

rosdep initialization without internet

asked 2013-04-22 18:00:25 -0500

Eruditass gravatar image

updated 2013-04-22 18:17:04 -0500

I have a machine that had ROS groovy installed but was not rosdep initialized/updated. The machine does not have internet access. I have nodes and nodelets on the machine, and the nodes will run but the nodelets complain about rosdep not being initialized. rospack profile does not help.

How can I initialize and update rosdep rospack_cache / rosstack_cache correctly?

This file did not work.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-04-22 19:46:35 -0500

tfoote gravatar image

rosdep init doesn't need a network connection. It's just a convenience method to add the default rosdep sources.

rosdep update downloads the sources and puts them into your rosdep cache. You simply need to copy ~/.ros/rosdep/sources.cache from a machine which has been updated onto the machine which has not yet.

Alternately you could copy all the source files onto your local harddrive and change the sources.list file to point to the file:/// url then rosdep update will work w/o network, but won't update when external systems update.

edit flag offensive delete link more

Comments

@tfoote Hi,tfoote, I've met the "rosdep update"problem recently, can you give me an example of creating "the sources.list file to point to the file:/// url then rosdep update", thanks a lot !!

Xure gravatar image Xure  ( 2014-04-02 17:26:45 -0500 )edit

@tfoote Hi,tfoote, I've tried your method to change the sources.list file like this"# os-specific listings first yaml http://localhost:11311/home/xu/sourcelists/osx-homebrew.yaml osx # generic yaml http://localhost:11311/home/xu/sourcelists/base.yaml yaml http://localhost:11311/home/xu/sourcelists/python.yaml yaml http://localhost:11311/home/xu/sourcelists/ruby.yaml gbpdistro http://localhost:11311/home/xu/sourcelists/fuerte.yaml fuerte # newer distributions (Groovy, Hydro, ...) must not be listed anymore, they are being fetched from the rosdistro index.yaml instead". And then, the error comes out "ERROR: unable to process source [http://localhost:11311/home/xu/sourcelists/osx-homebrew.yaml]: <urlopen error="" [errno="" 111]="" connection="" refused=""> (http://localhost:11311/home/xu/sourcelists/osx-homebrew.yaml)". Sorry for my poor English, haha...I've no idea then, looking forward to you help, thank you !

Xure gravatar image Xure  ( 2014-04-02 23:13:17 -0500 )edit

It looks like you've copied the files correctly. But you should be using syntax like "file:///home/xu/sourcelists/base.yaml yaml" no http or port number.

tfoote gravatar image tfoote  ( 2014-04-03 10:55:04 -0500 )edit

Thank you very much, I've tried type "rosdep update" for tow days, and it worked at last.....

Xure gravatar image Xure  ( 2014-04-03 15:03:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-22 18:00:25 -0500

Seen: 926 times

Last updated: Apr 22 '13