Ask Your Question
0

Can not install rosinstall because of python version conflict

asked 2013-04-17 21:07:43 -0500

Johannes gravatar image

updated 2014-01-28 17:16:14 -0500

ngrennan gravatar image

Hello, I'm having troubles installing ROS fuerte on Ubuntu Lucid. I did the installation accordign to the standard installation instructions for fuerte on lucid. But when installing rosinstall (sudo apt-get install python-rosinstall) I get an error regarding python versions (>2.7 needed but 2.6.5-0ubuntu1 installed). I read that with Lucid python 2.6 is the standard version. I do not face any troubles while installing rosdep. What I'm doing wrong?

Thanks Johannes

edit retag flag offensive close merge delete

Comments

Can you post the full apt error (gist.github.com)? It is likely that one of rosinstall's dependencies is now requiring py27.

William gravatar imageWilliam ( 2013-04-18 09:22:27 -0500 )edit

I'm having the same problem. There isn't much more to the error message. It's:

The following packages have unmet dependencies: python-rosinstall: Depends: python (>= 2.7) but 2.6.5-0ubuntu1 is to be installed E: Broken packages

jmacglashan gravatar imagejmacglashan ( 2013-04-30 11:46:17 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-05-06 14:00:56 -0500

tfoote gravatar image

There was a bug in the debian generator which created the python 2.7 dependency. The package now correctly depends on python>=2.6

It is highly recommended not to use the pip version over the apt version.

edit flag offensive delete link more
0

answered 2013-04-30 12:24:55 -0500

Okay, I got a solution. Basically you have to install the tools outside of apt-get. Specifically, this page was helpful...I have to put the link in a code block and obscure it partly because this website says that my karma isn't high enough to post links...

ros.org/doc/independent/api/rosinstall/html/rosws_tutorial.html#prerequisites

Where what you'll want to do is:

$ sudo apt-get install python-pip

$ sudo pip install -U rosinstall

Note that if you had an older version installed you will need to remove some files, as specified on the website I provided. E.g.,

$ sudo rm -rf /usr/local/lib/python2.6/dist-packages/rosinstall-0.5*

Seems to work then.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-17 21:07:43 -0500

Seen: 602 times

Last updated: May 06 '13