Ask Your Question
0

problem calibrating kinect ROS Fuerte

asked 2013-04-17 07:02:28 -0600

dalogi84 gravatar image

updated 2016-10-24 08:34:42 -0600

ngrennan gravatar image

Hello, I'm trying to calibrate a Kinect following the steps of that tutorial:

openni_launch/Tutorials/IntrinsicCalibration (I cannot type links)

All seems to run perfect, I can do the calibration, I can save it and commit it, but the problem appears when I see the path:

ls ~/.ros/camera_info/

It is suppose that I shuold see depth_*.yaml and rgb_*.yaml files, created by the calibration program, but I only have the RGB file! :( Do you know why only the RGB has been created? May I have to create the depth file manually? How? Can someone help me?

Thanx in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2013-04-17 09:42:22 -0600

ee.cornwell gravatar image

Here's a procedure I always use...make sure you calibrate the RGB and IR cameras separately

Kinect Calibration: RGB and IR Cameras

Packages Needed:

git clone https://github.com/ros-perception/image_pipeline.git

git clone https://github.com/ros-perception/image_common.git

Install dependences: rosdep install ______

Make packages: rosmake ______

Procedure:

For RGB Camera

1.) roscore

2.) rosrun openni_camera openni_node

3.) rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.059 image:=/rgb/image_raw rgb:=/rgb

Note: Size is number of rows of boxes-1 by number of columns of boxes-1.

Square is size of boxes in meters.

4.) Make sure Kinect is stationary. Move the checkerboard around slowly, changing the 6 degrees of freedom: x, y, z, roll, pitch, yaw.

5.) Keep changing the position of the checkerboard until the X, Y, Size, and Skew green bars on the right side of the screen are at a maximum.

6.) When the “Calibrate” button is lit, click it.

7.) When the “Save” button is lit, click it.

8.) This saves a .tar file in your system’s ‘tmp’ folder. Find it and extract the files somewhere handy. Inside the extracted folder will be pictures and a ost.txt file. Change the file extension to ost.ini and copy it to your sandbox/workspace.

9.) rosrun camera_calibration_parsers convert ost.ini cal.yml

10.) This saves the cal.yml in your sandbox/workspace. Change the extension to .yaml. Also, change the file name corresponding to what openni_node refrenced in the terminal when it was trying to find the calibration file. It’s usually something like “RGB_A00366812242050A”. Once the file name is changed, open the file in a text editor and change the default camera_name to “RGB_A00366812242050A”, or whatever name openni_node refrenced.

11.) Now, copy this .yaml file to home/.ros/camera_info folder

Note: The .ros folder might be a hidden folder

For IR Camera

1.) Procedure is the same except:

a.) Cover the IR projector with tape/paper

b.) Make sure you are in a low light environment with incandescent or halogen lighting. Fluorescent lighting interferes with the IR calibration. Also, make sure there is minimal movement…the IR camera is very finicky.

c.) rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.059 image:=/ir/image_raw ir:=/ir

edit flag offensive delete link more

Comments

Thanx very much! I found my error thanx to your explanation! :)

dalogi84 gravatar imagedalogi84 ( 2013-04-21 01:17:33 -0600 )edit

@ ee.cornwell ... You're simply a life saver. I go through a lot of documents for the calibration of my kinect, but your instructions are as clear as anyone asks. Thanks. I ran into a problem in step 9, though when I type ... rosrun camera_calibration_parsers convert ost.ini cal.yml it gives me error msgs ... ERROR] [1379405204.741886123]: Unable to open camera calibration file [ost.ini] [ERROR] [1379405204.741956956]: Failed to load camera model from file ost.ini Do you have any idea as for how I could fix this? Thanks.

eskendertamrat gravatar imageeskendertamrat ( 2013-09-18 06:15:18 -0600 )edit

It sounds like the .ini file is either not in your current directory or you didn't change the file extention .txt to .ini. That's the only thing I can think of...I've never came across this error. Make sure you are sourcing the command window and you cd to the directory where the .ini file is saved in.

ee.cornwell gravatar imageee.cornwell ( 2013-09-20 04:32:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-17 07:02:28 -0600

Seen: 758 times

Last updated: Apr 17 '13