Ask Your Question
0

Kinect not recognized with openni.launch [closed]

asked 2013-04-15 21:40:13 -0500

CarolineQ gravatar image

updated 2016-10-24 09:10:03 -0500

ngrennan gravatar image

Hello,

I am currently using two different computers to work with my robot, both of them are on ROS Groovy. I tried to use the Kinect with those computers using "roslaunch openni_launch openni.launch", but it works on one of the computers but not the other one. The only difference between the two computers is that I did some updates on the one that is not working well. The error message I get is : "No device connected"

I read some other questions about this problem, so my Kinect is connected on a USB 2.0, and I tried "rmmod -f gspca_kinect" but it's not working.

I read those questions : http://answers.ros.org/question/60562/ubuntu-12042-and-openni_launch-not-detecting-kinect-after-update/

http://answers.ros.org/question/60576/microsoft-kinect-not-connected/

But it seems that nobody found a solution to the problem for the moment.

Caroline

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by CarolineQ
close date 2013-04-16 21:57:47

Comments

Have you installed the old NITE 1.5.2 ? You should first use the ./uninstall, then the ./install. Which Ubuntu are you on ? If 12.10, USB 3.0 is not a problem, otherwise it is.

Stephane.M gravatar imageStephane.M ( 2013-04-15 22:58:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-16 21:57:08 -0500

CarolineQ gravatar image

The solution was to reinstall PrimeSense Sensor : the explanation was given here http://answers.ros.org/question/60562/ubuntu-12042-and-openni_launch-not-detecting-kinect-after-update/

As for djtubig-malicex in this post, I had the same version but it was not working, in the version in the link given it works.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-15 21:40:13 -0500

Seen: 3,334 times

Last updated: Apr 16 '13