ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

apt conflict installing libsdl1.2-dev (E: broken package) for map_server (electric on lucid)

asked 2013-04-13 00:20:23 -0600

JaRu gravatar image

updated 2014-01-28 17:16:10 -0600

ngrennan gravatar image


I tried to install, respectively upgrade the libsdl-image1.2-dev, because I need it for another package. (map_server)

sudo apt-get update; sudo apt-get dist-upgrade; sudo apt-get install libsdl-image1.2-dev

But I get the command that libsdl-image1.2-dev depends on libsdl1.2-dev (>= 1.2.10), but should not installed, because E: broken package

(When I try to install libsdl1.2-dev, could not install because depends on libsdl1.2debian. But libsdl1.2-debian, but this is already the latest version.)

Does somebody know what I can do that it works? (I use ROS electric, Ubuntu Lucid 10.04)


edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-04-17 00:12:11 -0600

updated 2013-04-17 00:15:59 -0600

The "broken package" message indicates a conflict in your debian packages that dpkg could not resolve. For example, you have package A installed, which depends on package B in version < x.x.x. You want to install package C, which depends on package B in version > x.x.x; this conflict cannot be resolved.

Sometimes you can manually resolve those conflicts, but this requires some level of knowledge of apt/dpkg. In short, you need to use a tool such as aptitude to find the source of the conflict and see whether there is a combination of package versions that resolves it. Since I don't have a Ubuntu 10.04 available for testing, I can't reproduce the problem here.

One thing you could try is removing the offending package (this will also require you to remove all dependent packages), and then installing the packages you need, hoping that the resolver will figure out a solution this time.

My advice would be to upgrade to Ubuntu 11.10 "oneiric", since that's the latest version that supports ROS Electric, and hope the error goes away. Maybe better do a clean reinstall of Ubuntu 11.10, since your previous map_server question indicates that your /opt/ros/ directory was messed up.

P.S.: I've updated your question title to be more descriptive in the hope of attracting someone who has a solution for your specific problem.

edit flag offensive delete link more

Question Tools


Asked: 2013-04-13 00:20:23 -0600

Seen: 1,328 times

Last updated: Apr 17 '13