Ask Your Question
0

Problem with rosbuild workspace in Groovy

asked 2013-04-08 21:48:10 -0600

ZdenekM gravatar image

updated 2013-04-08 22:27:15 -0600

Hi,

I'm trying to migrate from Electric to Groovy (Ubuntu 11.10, 64bit). Trying to setup rosbuild workspace for my old packages using this tutorial. But getting some weird error:

imaterna@fitpc:~$ mkdir ~/rosbuild_ws
imaterna@fitpc:~$ cd ~/rosbuild_ws
imaterna@fitpc:~/rosbuild_ws$ rosws init . /opt/ros/groovy
ERROR: Invalid scm entry having no uri attribute for path /opt/ros/groovy/setup.sh
Error: rosinstall failed: None

Any idea? Many thanks in advance...

UPDATE: There is rosws and wstool... I'm bit confused. What's the difference and which of them should I use?

UPDATE2: Maybe there is something wrong with my ROS installation... I can't even start rqt_console:

imaterna@fitpc:~$ rqt_console 
WARNING: Package name "swig-wx" does not follow the naming conventions. It should start with a lower case letter and only contain lower case letters, digits and underscores.
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/rosdep2/rospack.py", line 58, in init_rospack_interface
    lookup = _get_default_RosdepLookup(Options())
  File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 107, in _get_default_RosdepLookup
    verbose=options.verbose)
  File "/usr/lib/pymodules/python2.7/rosdep2/sources_list.py", line 522, in create_default
    sources = load_cached_sources_list(sources_cache_dir=sources_cache_dir, verbose=verbose)
  File "/usr/lib/pymodules/python2.7/rosdep2/sources_list.py", line 429, in load_cached_sources_list
    with open(cache_index, 'r') as f:
IOError: [Errno 13] Operace zamítnuta: '/home/imaterna/.ros/rosdep/sources.cache/index'
[rospack] Error: could not call python function 'rosdep2.rospack.init_rospack_interface'
[librospack]: error while executing command
terminate called after throwing an instance of 'pluginlib::LibraryLoadException'
  what():  rospack could not find the qt_gui package containing qt_gui_cpp::Plugin
Neúspěšně ukončen (SIGABRT)

UPDATE 3: Removed ROS related stuff in /usr/local/lib/python2.7/dist-packages/ (rosinstall, vcstools) but it didn't help. Now I can't even run rosws:

imaterna@fitpc:~$ rosws --version
Traceback (most recent call last):
  File "/usr/local/bin/rosws", line 4, in <module>
    import pkg_resources
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2676, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 552, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: rosinstall==0.5.22
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-04-08 22:47:27 -0600

ZdenekM gravatar image

Solved by removing old stuff with:

sudo rm /usr/local/bin/ros*
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-08 21:48:10 -0600

Seen: 440 times

Last updated: Apr 08 '13