Ask Your Question
0

AMCL fails to load map [closed]

asked 2013-04-05 09:51:29 -0500

updated 2014-01-28 17:16:03 -0500

ngrennan gravatar image

Hello,

I am trying to navigate around a map that I built using the husky navigation gmapping demo. I have built the map and saved it in my home folder. When I try to run the amcl demo it fails though. I get the code:

core service [/rosout] found
process[map_server-1]: started with pid [18464]
[ERROR] [1365180853.546403072]: Map_server could not open ~/map1.yaml.
process[amcl-2]: started with pid [18475]
process[move_base-3]: started with pid [18572]
[map_server-1] process has died [pid 18464, exit code 255, cmd /opt/ros/groovy/stacks/navigation/map_server/bin/map_server ~/map1.yaml __name:=map_server __log:=/home/lemur2/.ros/log/cbfe7674-9e0e-11e2-ac94-0090f5c994bc/map_server-1.log].
log file: /home/lemur2/.ros/log/cbfe7674-9e0e-11e2-ac94-0090f5c994bc/map_server-1*.log

When I look for the log file there is nothing there. Any ideas about what is going on?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Icehawk101
close date 2013-04-06 09:53:45

Comments

Does the file ~/map1.yaml exist?

dornhege gravatar imagedornhege ( 2013-04-05 10:39:32 -0500 )edit

Indeed it does.

Icehawk101 gravatar imageIcehawk101 ( 2013-04-05 10:49:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-04-06 09:53:28 -0500

Not really a full answer, but I found out that I can have amcl use the /map topic rather than a saved map. I tried that and it no longer gave me the error. amcl is still not working, but that is for another thread.

edit flag offensive delete link more

Comments

Can you please explain how exactly you use the map topic with amcl?

schultza gravatar imageschultza ( 2014-09-12 02:35:44 -0500 )edit

You need to load a map using the map_server node, and then set the use_map_topic argument in amcl to true.

Icehawk101 gravatar imageIcehawk101 ( 2014-09-29 09:33:22 -0500 )edit

Question Tools

Stats

Asked: 2013-04-05 09:51:29 -0500

Seen: 1,142 times

Last updated: Apr 06 '13