Ask Your Question
0

publish to android node

asked 2013-03-31 18:32:45 -0500

Gosu gravatar image

Hi, I have installed the android_tutorial_pubsub on android device and able to connect to roscore on my computer (I see the chatter topic in the topic lists). I run a Talker node on my computer and see the data publish to the chatter topic correctly. However, the rosTextView node on my android device doesnt show anything.

Do you know how to publish data to a node on android device?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

can you run rxgraph and see that both your rosTextView and talker node both appear?

PeterMilani gravatar imagePeterMilani ( 2013-04-02 12:03:05 -0500 )edit

Yes, both the node appear, but my talker node only publish to /rostopic.

Gosu gravatar imageGosu ( 2013-04-04 03:26:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-04 04:45:22 -0500

damonkohler gravatar image

updated 2013-04-04 04:46:40 -0500

In android_tutorial_pubsub, the NodeConfiguration is private. Nodes on your PC will not be able to communicate with those on your Android device.

Try changing the NodeConfiguration to a public one. See the NodeConfiguration.newPublic documentation.

edit flag offensive delete link more

Comments

I have tried but no luck, the rosTextView node still doesnt receive anything

Gosu gravatar imageGosu ( 2013-04-04 05:08:27 -0500 )edit

Check your ROS_IP and ROS_MASTER_URI settings. Also check the host string you're using in your NodeConfiguration.

damonkohler gravatar imagedamonkohler ( 2013-04-04 05:20:33 -0500 )edit

Thank you very much! Its worked! I forgot to set ROS_IP and ROS_MASTER_URI variables

Gosu gravatar imageGosu ( 2013-04-04 05:35:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-31 18:32:45 -0500

Seen: 216 times

Last updated: Apr 04 '13