Ask Your Question
0

ERROR: Gradle 'android_10' project refresh failed

asked 2017-12-25 14:53:19 -0500

updated 2017-12-27 12:44:14 -0500

ROS Android

Error:Unsupported method: BaseConfig.getApplicationIdSuffix().
The version of Gradle you connect to does not support that method.
To resolve the problem you can change/upgrade the target version of Gradle you connect to.
Alternatively, you can ignore this exception and read other information from the model.

I am trying to use ROSJava in Android Studio 3.0.1 but following the installation instructions given here leads to this error in Android Studio. Please advise.

edit retag flag offensive close merge delete

Comments

A question with only an error message isn't a question.

jayess gravatar image jayess  ( 2017-12-25 18:42:48 -0500 )edit

I have updated the question. Sorry for the incomplete question.

akshayk07 gravatar image akshayk07  ( 2017-12-26 04:27:03 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-01-31 13:46:32 -0500

jubeira gravatar image

It sounds like you accepted to change the Gradle version when Android Studio prompted if you wanted to do so.

Android Studio will find that there's a new Gradle version when you open a project, and a popup will appear to change it. Don't do it; newer Gradle versions may be incompatible. Just keep using the Gradle wrapper as it is in the projects; this doesn't have to do with Android Studio versions (I'm using 3.x.x and it works).

edit flag offensive delete link more
0

answered 2017-12-27 12:44:55 -0500

I managed to solve the issue by using Android Studio 2.x.x instead of the newer 3.x.x versions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-25 14:53:19 -0500

Seen: 557 times

Last updated: Jan 31 '18