Ask Your Question
1

Openni registration problem

asked 2013-03-28 06:17:56 -0500

jcc gravatar image

updated 2014-04-20 14:09:30 -0500

ngrennan gravatar image

Hi,

I'm having a problem with the openni registration on a kinect. As many people around here when i enable the depth_registration option i only receive NaN's. This is on a fresh install of booth ubuntu 12.04 and ros groovy from yesterday. I allready tried to follow this "tutorial" here and here because it's the same problem, but i still can't get the thing to work, and running the OpenNi samples every thing is great.

This is a problem that exists for a long time and no solution yet... It's very annoying because i need it for my thesis

What can i try to solve this?

Thanks

edit retag flag offensive close merge delete

Comments

I am having the same problem on my laptop: HP Mini 210 w/ Intel Atom, Ubuntu Precise-Fuerte. Depth registration set to true in openni.launch causes all NAN values. I am betting this is system dependent because my other laptop with an AMD processor and graphics card works well with openni depth registration (same software).

ee.cornwell gravatar image ee.cornwell  ( 2013-03-28 09:33:59 -0500 )edit

I also think it is hardware dependent. working on my room there is another studend with a different pc and everything works fine (just by instaling openni-camera and launch). For me the strange thing is that the OpenNi binaries works flawless on every pc, but the ROS (and PCL?) library doesn't

jcc gravatar image jcc  ( 2013-03-28 16:28:28 -0500 )edit

If you have this problem please say it on the github page. here is my issue ticket: https://github.com/ros-drivers/openni_camera/issues/13

They didn't seem to find that important (it seams they didn't even read thing right), maybe if more users put the same issue...

jcc gravatar image jcc  ( 2013-04-15 05:01:44 -0500 )edit

Hi ! I am struggling with the same problem. Did you find a solution ?

Lucile gravatar image Lucile  ( 2013-05-23 03:19:41 -0500 )edit

My "solution" was to switch to a 64bits ubuntu.

jcc gravatar image jcc  ( 2013-05-23 03:23:35 -0500 )edit

Ok. Thank you. My Turtlebot was delivered with a 32 bits computer, so I'll have to deal with it.

Lucile gravatar image Lucile  ( 2013-05-23 21:32:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-12-19 05:12:43 -0500

o3p7s5 gravatar image

This is a bug in Libopenni-dev. It does not work proper with 32 bit OS. You may work with an older version or install a 64 bit OS. Regards ,O3

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-28 06:17:56 -0500

Seen: 1,053 times

Last updated: Dec 19 '13