Ask Your Question
0

gmapping [SKIP] No rule to make target None

asked 2013-03-24 07:00:56 -0500

Dereck gravatar image

I'm am trying to build gmapping from source and for some reason it's not building the executables....

In a rosbuild workspace I used:

rosws set slam_gmapping --git git@github.com:dawonn/slam_gmapping.git
rosws update gmapping
source ./setup.bash
roscd gmapping
rosmake

[rosmake-0] Starting >>> gmapping [ make ]
[rosmake-0] Finished <<< gmapping [SKIP] No rule to make target None

$ rosrun gmapping slam_gmapping

[rosrun] Couldn't find executable named slam_gmapping below /home/dereck/rosbuild_ws/slam_gmapping/gmapping

rosrun gmapping < tab > < tab >

libconfigfile.so liblog.so libsensor_base.so libsensor_range.so test_map.py
libgridfastslam.so libscanmatcher.so libsensor_odometry.so libutils.so

Any idea what I'm doing wrong here?

Thanks!

edit retag flag offensive close merge delete

Comments

It's hard to tell what version of that repository to use. The master branch has a different commit signature than what looks like the latest release, tagged slam_gmapping-1.2.7. You might try that one.

joq gravatar imagejoq ( 2013-03-24 07:20:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-24 07:58:39 -0500

Dereck gravatar image

after running rosmake:

roscd gmapping
cd build
make
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-24 07:00:56 -0500

Seen: 698 times

Last updated: Mar 24 '13