Ask Your Question
0

Problem while trying to install rosaria on groovy on Ubuntu 12.10

asked 2013-03-18 09:09:13 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello,

I'm following the tutorial on how to use rosaria, available on the link: http://_www.ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA

I'm running Ubuntu 12.10 on my machine. I installed Groovy successfully using the tutorial available on: http://_www.ros.org/wiki/groovy/Installation/Ubuntu

When I run the command 'rosmake ROSARIA', nothing seems to be built. Instead, it seems to be finding a ROS_NOBUILD file and ignoring instead of building the package. I neither created the file nor can I find it anywhere in ROSARIA directory.

When I run the command 'rosrun ROSARIA RosAria' it doesn't find the executable named RosAria, confirming that it isn't being built.

Relevant terminal output available on: http://_pastebin.com/0aN7AETa

edit retag flag offensive close merge delete

Comments

Does rospack find command show the path to ROSARIA? Also check your ROS_PACKAGE_PATH variable.

gustavo.velascoh gravatar image gustavo.velascoh  ( 2013-03-18 17:15:02 -0500 )edit

'rospack find ROSARIA' returns $HOME/ros/amor-ros-pkg/ROSARIA as expected.

echoing 'ROS_PACKAGE_PATH' variable returns: $HOME/ros/amor-ros-pkg:/opt/ros/groovy/share:/opt/ros/groovy/stacks

Where $HOME is the path to my home directory.

mullah_nasruddin gravatar image mullah_nasruddin  ( 2013-03-19 06:17:12 -0500 )edit

have you tried catkin_make? As far as I know you have to set a workspace before. Did you set a workspace?

gustavo.velascoh gravatar image gustavo.velascoh  ( 2013-03-19 06:21:47 -0500 )edit

I set up a workspace using 'rosws' as explained in the tutorial for rosaria installation. I didn't try catkin_make yet, I'll look onto it and report back.

mullah_nasruddin gravatar image mullah_nasruddin  ( 2013-03-19 06:35:30 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-20 04:00:12 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I'm not yet sure why rosmake doesn't work, but you can manually compile it like this:

cd amor-ros-pkg/ROSARIA
mkdir build
cd build
cmake ..
make

Or use this makefile: https://reedatadept-rosaria.googlecode.com/hg/ROSARIA/Makefile and then run "make" in the amor-ros-pkg directory.

edit flag offensive delete link more

Comments

I could successfully run make now, but It can't find aria.h . If I'm understanding right, I'm currently missing a dependency, libaria. When I run 'rosdep check ROSARIA' , I'm getting: 'ERROR[ROSARIA]: Cannot locate rosdep definition for [libaria]' I don't know how to correctly install it though.

mullah_nasruddin gravatar image mullah_nasruddin  ( 2013-03-20 04:34:57 -0500 )edit

This worked for me. I had to copy the compiled library from ROSARIA/build/devel/lib/ROSARIA/RosAria to ROSARIA/RosAria before I could rosrun it, though.

RafBerkvens gravatar image RafBerkvens  ( 2013-03-20 04:59:09 -0500 )edit

after I use the make command it seems to just stop part way through[ 16%] Built target ROSARIA_gencpp [ 33%] Built target ROSARIA_genlisp [ 66%] Built target ROSARIA_genpy [ 83%] Built target ROSARIA_gencfg [100%] Building CXX object CMakeFiles/RosAria.dir/RosAria.cpp.o /home/**/ros/amor-ros-pkg/R

Guru666 gravatar image Guru666  ( 2013-03-27 08:47:38 -0500 )edit

I am also unable to build... I get the error that mullah_nasruddin got above... "can't fine aria.h". The tutorial, "ROSARIA's rosmake configuration will download a recent version of the source code for the ARIA library from http://MobileRobots.com and compile it as well, but I guess that isn't happening?

gershon gravatar image gershon  ( 2013-03-27 13:35:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-18 09:09:13 -0500

Seen: 446 times

Last updated: Mar 20 '13