Ask Your Question
0

waiting for a service to be advertised !

asked 2013-03-18 06:57:42 -0500

updated 2013-03-18 07:41:02 -0500

joq gravatar image

hi, I'm working with tabletop_object_detector and household_objects_database I typed these commands in my terminal :

 roscore
 rosmake tabletop_object_detector
 rosmake household_objects_database
 rospack find tabletop_object_detector
 roscd tabletop_object_detector
 roslaunch tabletop_object_detector tabletop_object_recognition.launch

after the last command , the terminal tells me that :

  • INFO] [1363624742.520172331]: waitForService: Service [/objects_database_node/get_model_mesh] has not been advertised, waiting...

and when I tried to call these service , It told me that it's not found !

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-03-21 13:22:01 -0500

Matei Ciocarlie gravatar image

You will also need to launch household_objects_database/launch/objects_database_local_server.launch with a properly populated .yaml file with the right connection parameters for your local PostgreSQL server.

edit flag offensive delete link more

Comments

when I type this command >> It tells me that : [household_objects_database/launch/objects_database_local_server.launch] does not exist. please specify a package and launch file

RiskTeam gravatar imageRiskTeam ( 2013-03-21 13:57:41 -0500 )edit

package: household_objects_database. Launch file: objects_database_local_server.launch

Matei Ciocarlie gravatar imageMatei Ciocarlie ( 2013-03-22 06:39:27 -0500 )edit

Still , having the same error !

RiskTeam gravatar imageRiskTeam ( 2013-03-22 09:48:19 -0500 )edit
2

answered 2013-03-19 06:45:02 -0500

Rookdroid gravatar image

Check rxgraph to make sure that your nodes are subscribing to the correct service topics.

edit flag offensive delete link more

Comments

The output of ( rxgraph) only contains : rosout , tabletop_object_recognition nodes :(

Does this mean that household_objects_database doesn't work ??

RiskTeam gravatar imageRiskTeam ( 2013-03-21 13:17:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-18 06:57:42 -0500

Seen: 889 times

Last updated: Mar 21 '13