ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Skeleton tracking in ROS is not working.

asked 2013-03-17 23:51:02 -0500

jaya gravatar image

updated 2013-03-18 05:31:59 -0500

Hi all

I am using ROS Fuerte+Ubuntu 12.04. In skeleton tracking, I downloaded the pi_tracker and skeleton_markers package. Then I run the following commands:

 cd ~/ros_workspace/
 svn checkout http:_//;
 svn checkout http:_//;
 cd pi_tracker/;
 cd ../skeleton_markers/

I didn't get any error. Then I run roscore command in one terminal

In another terminal, I run roslaunch skeleton_markers markers_from_tf.launch, I was getting error How to solve

'No such file or directory: u'/opt/ros/fuerte/stacks/openni_camera/launch/openni_node.launch'?

I modified these errors with the help given in the following link :

but again when I run roslaunch skeleton_markers markers_from_tf.launch, it is showing the following error

[openni_tracker-22] process has died [pid 21752, exit code 18, cmd /opt/ros/fuerte/stacks/openni_tracker/bin/openni_tracker __name:=openni_tracker __log:=/home/jaya/.ros/log/851ade76-8d44-11e2-a6f7-a088b43d45c4/openni_tracker-22.log]. log file: /home/jaya/.ros/log/851ade76-8d44-11e2-a6f7-a088b43d45c4/openni_tracker-22*.log

Please help me. How could I do skeleton tracking in ROS fuerte+ubuntu 12.04.


edit retag flag offensive close merge delete


just remove the underscore after the http in every URL. I don't have enough karma points to publish links :-(

jaya gravatar image jaya  ( 2013-03-17 23:52:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-03-18 05:17:50 -0500

Rookdroid gravatar image

I think you are having issues because you don't have the openni_kinect _http:_// stack installed. You might want to do that first. Also just a small note if you are having other issues you might need to download the Openni Nite 1.5.2 SDK.

edit flag offensive delete link more


@Rookdroid is possibly right about having to install Nite 1.5.2. See this question

jarvisschultz gravatar image jarvisschultz  ( 2013-03-18 05:49:53 -0500 )edit

Please remember, that just after download NITE 1.5.2, FIRST run the uninstall script, then the install script. Some weird behaviors sometimes appears if you forget to do so.

Stephane.M gravatar image Stephane.M  ( 2013-03-18 22:00:51 -0500 )edit

In ROS, when I have installed ROS(Fuerte) in ubuntu 12.04 using sudo apt-get install ros-fuerte-desktop-full then all the packages supported by ROS should installed. IT is showing there is a package Openni_kinect and openni_nite ,but I am not able to do skeleton tracking. :-( Please help me

jaya gravatar image jaya  ( 2013-03-19 23:23:46 -0500 )edit

No. It installs only some mnadatory packages. Not all packages (hopefully !). You have to do a "sudo apt-get install ros-fuerte-openni*" to install all openni related packages, and also go to the NITE page, and install NITE 1.5.2...

Stephane.M gravatar image Stephane.M  ( 2013-03-19 23:50:38 -0500 )edit

Question Tools

1 follower


Asked: 2013-03-17 23:51:02 -0500

Seen: 583 times

Last updated: Mar 18 '13