Ask Your Question
4

MoveIt! Rviz Plugin - No interactive markers visible/available

asked 2013-03-09 07:19:02 -0600

viovio gravatar image

updated 2013-03-14 13:30:22 -0600

Hello to all,

I created a Robot-Config via MoveIt! Setup Assistant. The Robot is a simple 6 Dof Robot.

When I start it with the Rviz Moveit Plugin the interactive markers are not displayed. (After I click on "Interact"). I suspect the End-Effector is not correctly set by me.

RVIZ:

image description

Screenshots of the MoveIt Setup Assistant:

1. image description

2. image description

I set for both plannings groups the "KDLKinematicsPlugin" as Solver on default values. I followed this tutorial for the pr2-robot.

My .launch-file:

<launch>

<include file="$(find tx60l_final3)/launch/upload_tx60l.launch"/>

<node pkg="tf" type="static_transform_publisher" name="odom_broadcaster" args="0 0 0 0 0 0 odom_combined base_footprint 100" />

<node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
 <param name="/use_gui" value="false"/>
</node>

<node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" respawn="true" output="screen"/>

  <include file="$(find tx60l_final3)/launch/move_group.launch">
    <arg name="allow_trajectory_execution" value="false"/>
  </include>

<include file="$(find tx60l_final3)/launch/moveit_rviz.launch"/>

</launch>

Edit (no gazebo-part in urdf): See here the Terminal-Output.

Info: Removing and adding "MotionPlanning" inside Rviz didn't help.

Edit (working Links): Here you can download my robot-description. Here you can download my urdf-folder.

Update: If I set the "fixed_frame" to a link of the robot itself, interactive markers for joint a4 show up. (See picture below) But I need interactive markers in joint5. If I let "fixed_frame" set on "base_footprint" or "odom_combined" (as it should be, I think) and "plan and execute" for a random query MoveIt! crashes (output)

image description

Update: Now the interactive markers work correctly. Many Thanks to all supporters.

viovio

edit retag flag offensive close merge delete

Comments

Please mark an answer as correct, so the question is flagged as "answered". Glad it's working for you! Consider looking into http://ros.org/wiki/Industrial, which has several tutorials and templates for controlling your industrial robot through ROS. We'd love to add support for Staubli to ROS-I !

Jeremy Zoss gravatar imageJeremy Zoss ( 2013-03-14 16:54:09 -0600 )edit

did you tried to connect that to real robot or the simulator ?

ROSkinect gravatar imageROSkinect ( 2015-03-03 10:00:49 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-03-14 05:28:17 -0600

updated 2013-03-14 07:27:17 -0600

To me, it looks like the issue is that your joint_state_publisher is crashing due to a malformed robot URDF. See the following snippet from your error log:

xml.parsers.expat.ExpatError: unbound prefix: line 3, column 4
[joint_state_publisher-3] process has died

I was able to reproduce the error using the tx60l.urdf supplied in your links. The issue here is with the <gazebo> section in your URDF. The joint_state_publisher uses a python minidom XML parser, which is more picky about XML syntax than the TinyXML C++ parser used in much of the rest of ROS (including the check_urdf test you ran earlier). Even though the TinyXML parser can handle your URDF, the minidom parser requires a little bit more help...

To fix the error, you have two options:

  1. remove the <gazebo> section from your URDF
  2. or update the URDF to a "more correct" format:
    1. move the <gazebo> section inside the <robot> section
    2. add xmlns qualifiers to the robot tag as shown:

<robot name="TX60L">
       xmlns:controller="http://playerstage.sourceforge.net/gazebo/xmlschema/#controller"
       xmlns:interface="http://playerstage.sourceforge.net/gazebo/xmlschema/#interface">
  <gazebo>
    ...
  </gazebo>
  <link name="base_link">
    ...
</robot>

Using these changes, I was able to get the joint_state_publisher to run without errors. I expect this will also fix the issue you were having with missing interactive markers.

edit flag offensive delete link more

Comments

Thx for your answer. I updated the links, so it must work now. My urdf file seems to be fine according to check_urdf.

viovio gravatar imageviovio ( 2013-03-14 06:12:49 -0600 )edit

In the meantime I also noticed this. I removed it and the joint_state_publisher starts correctly. But this doesn't solve the problem. But I noticed something interesting: When setting the fixed_frame from odom_combined to a link of the robot itself, interactive markers appear for the a4-link!

viovio gravatar imageviovio ( 2013-03-14 08:03:28 -0600 )edit

I think you are seeing the correct behavior. What are you expecting to see? For a fixed robot, you shouldn't need to define odom_combined. It is appropriate to set the fixed_frame in rviz to base_link of your robot.

Jeremy Zoss gravatar imageJeremy Zoss ( 2013-03-14 09:25:25 -0600 )edit

Similarly, at4 is the last link in your robot_arm group. That's where the markers should be shown. If you prefer to include the at5 link, then you need to add it to your robot_arm group. This may require you to use a dummy (fixed) joint for the EE group, if you don't have a true gripper.

Jeremy Zoss gravatar imageJeremy Zoss ( 2013-03-14 09:36:38 -0600 )edit

Thx. I followed your comment and the interactive markers are now on their right spot.

viovio gravatar imageviovio ( 2013-03-14 11:24:43 -0600 )edit
2

answered 2017-02-16 13:48:36 -0600

dhood gravatar image

If anyone else comes across this issue, you can get more debug info with the following steps:

  1. In the Displays panel of RViz, click Add > By topic > select InteractiveMarkers under /rviz_moveit_motion_planning_display
  2. In my case I see the error "Error getting time of latest transform between /world and world: (error code: 1)" for this interactive marker in the Displays panel.

This helped me debug that my issue is related to the robot being in a namespace. (A quick fix in this case is to manually publish the transform with "rosrun tf static_transform_publisher 0 0 0 0 0 0 1 /world /{robot_namespace}/world 10")

edit flag offensive delete link more

Comments

Your error is similar to mine, but when I try your fix it doesn't work for me. Could it be a problem simply with having slashes?

oldham gravatar imageoldham ( 2017-07-26 09:41:56 -0600 )edit

what's the error that you see? the frames with/without a slash in the error message that I mentioned have significantly different meaning: '/world' is a global frame and 'world' is a local frame. Probably whatever was publishing it as a local frame (I forget what) should have been doing it as global

dhood gravatar imagedhood ( 2017-07-26 12:38:20 -0600 )edit

Ah okay! I was revising a different deprecated MoveIt! tutorial but I found the issue once the global/local difference was made clear. Thanks for your help.

oldham gravatar imageoldham ( 2017-07-26 13:44:42 -0600 )edit

glad to hear that helped

dhood gravatar imagedhood ( 2017-07-26 14:41:23 -0600 )edit
1

answered 2013-03-09 08:25:25 -0600

fergs gravatar image

Have you tried disabling and then re-enabling the MoveIt plugin? I've noticed in the past that if RVIZ starts before MoveIt is really up and running, the markers don't work.

edit flag offensive delete link more

Comments

Not yet, how can I do that?

viovio gravatar imageviovio ( 2013-03-10 00:03:34 -0600 )edit

On each plugin there is a checkbox next to it to enable/disable it.

fergs gravatar imagefergs ( 2013-03-10 00:27:16 -0600 )edit

Unfortunately it does not work. I guess you mean the checkbox next to MotionPlanning in Panel "Displays".

viovio gravatar imageviovio ( 2013-03-10 01:28:38 -0600 )edit
1

I confirm that disabling/enabling the MotionPlanning panel does fix the issue for me.

severin gravatar imageseverin ( 2013-03-13 03:43:51 -0600 )edit
0

answered 2013-09-04 04:08:10 -0600

Kamil Kotek gravatar image

updated 2013-09-04 04:13:14 -0600

I have same problem, but nothing help me. After launching demo.launch it writes one error: "[ INFO] [1378302606.416030588]: No root joint specified. Assuming fixed joint process[mongo_wrapper_ros_romesy_desktop_2173_3455346243933734730-4]: started with pid [2228]"

"[ INFO] [1378302606.461072650]: rviz version 1.9.32"

"[ INFO] [1378302606.461179802]: compiled against OGRE version 1.7.4 (Cthugha)"

"[ INFO] [1378302606.653216609]: OpenGl version: 2.1 (GLSL 1.2)."

[ERROR] [WallTime: 1378302606.779255] Execution failed: [Errno 2] No such file or directory

"[ INFO] [1378302606.887842389]: Publishing maintained planning scene on 'monitored_planning_scene'"

Rviz starts, everythings works, but i can't see and use interactive markers and also have problem with connecting to Warehouse.

edit flag offensive delete link more

Comments

Is the move_group node getting started? Does the planning library show in red no planning library loaded?

cdrwolfe gravatar imagecdrwolfe ( 2013-09-04 08:46:50 -0600 )edit

move_group is running (visible in rqt_graph) and libary is loaded(green OMPL)

Kamil Kotek gravatar imageKamil Kotek ( 2013-09-05 21:01:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-03-09 07:19:02 -0600

Seen: 5,962 times

Last updated: Sep 04 '13