openni_tracker [ERROR]: Find user generator failed [closed]

asked 2013-03-08 01:08:23 -0500

Geropan gravatar image

updated 2016-10-24 08:35:06 -0500

ngrennan gravatar image

Hello everyone,

I know this is an old issue, but I haven't been able to solve it. After applying the workaround described in http://answers.ros.org/question/42654/openninite-incompatible-in-fuertegroovy-on-precise/, I still get the following error:

[ERROR]: Find user generator failed: This operation is invalid!

I installed 1.5.2.21 version of NITE as described in the previous link, but when I run niReg -l Fuerte/Precise openni-dev I get several messages similar to the following in the output:

Failed loading lib: /usr/lib/libXnVHandGenerator_1_5_2.so: wrong ELF class: ELFCLASS64

   132635 WARNING    Failed to load '/usr/lib/libXnVHandGenerator_1_5_2.so' - missing dependencies?

Which mismatch the output you are supposed to get after applying succesfully the workaround.

I have tried to uninstall all openni packages in ros by sudo apt-get remove ros-fuerte-openni* and reinstalling everything again with no luck.

Has anyone any ideas how to solve this issue?

Thank you in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-06-16 19:27:07.077784

Comments

2

Did you download the appropriate NITE for your system architecture from this page? You can use lscpu to determine your system's architecture.

jarvisschultz gravatar imagejarvisschultz ( 2013-03-08 05:11:27 -0500 )edit

Also, make sure you use NITE's uninstall script, before installing the 1.5.2.XX library. Uninstalling ros-fuerte-openni-* packages should not be necessary (wasn't in my case at least).

bit-pirate gravatar imagebit-pirate ( 2013-06-30 13:37:49 -0500 )edit

Please, share the version of Linux and ROS you are using. I have tried what you described on ubuntu 15.04 and ROS jade, openni does not work there.

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-01-19 00:57:24 -0500 )edit