Ask Your Question
0

No depth data with kinect on Turtlebot 2

asked 2013-03-04 23:20:28 -0500

CarolineQ gravatar image

updated 2016-10-24 08:35:27 -0500

ngrennan gravatar image

Hello,

I am using a Turtlebot2 with groovy. I am trying to follow the 3D visualization tutorial in Turtlebot tutorials but when I want to visualize things in rviz I have the image of the kinect but no depth data and no laser scan. I don't have any error message in rviz, but nothing appears on the screen.

The problem is that when I connect the kinect to my desktop computer and not to the turtlebot's laptop (and use the same launch files) everything is working fine.

Do you have some clues ?

Caroline

edit retag flag offensive close merge delete

Comments

hi, I am working on turtlebot2 too. I see that you have successfully setup the robot. Basically, I am having troubles setting up the robot. Could I use your help please ? Could you give me your e-mail id or something by which I could communicate with you ? Mine is prasannasastra@live.com.

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-05 00:08:21 -0500 )edit

Please check that you are not plugging the Kinect in a USB 3.0 port. Most modern laptops come with one or two 3.0, and Kinect is incompatible with them.

jorge gravatar image jorge  ( 2013-03-05 12:11:54 -0500 )edit
1

@prasanna.kumar if you need help beyond ROS answers, feel free to join the Turtlebot mailing list (ros-sig-turtlebot@googlegroups.com) or join the ROS chat room on IRC (http://www.ros.org/wiki/Get%20Involved#IRC).

bit-pirate gravatar image bit-pirate  ( 2013-03-05 12:37:01 -0500 )edit

Hi ! I see that we've been through the same issues. I had this problem too and didn't manage to fix it. Did you find a solution ?

Lucile gravatar image Lucile  ( 2013-06-10 01:34:30 -0500 )edit

I had this problem some time ago. I installed Openni and SensorKinect from source (OpenNI-Bin-Dev-Linux-x86-v1.5.4.0, Sensor-Bin-Linux-x86-v5.1.2.1) and updated my packages and everything works now.

CarolineQ gravatar image CarolineQ  ( 2013-06-10 21:24:17 -0500 )edit

CarolineQ, can you help me? please! I tried to install openni and sensorkinect based on http://ramsrigoutham.com/2012/07/08/getting-started-with-kinect-on-ubuntu-12-04-openni-nite-simpleopenni-and-processing/ however, rviz still doesn't work. My e-mail: ezamora70@hotmail.com.

Herick gravatar image Herick  ( 2013-11-11 14:21:14 -0500 )edit

Hi Herick. I have a new computer on which I am also unable to make Rviz work well. It's probably the same problem but I don't have any idea of how to make it work... Sorry.

CarolineQ gravatar image CarolineQ  ( 2013-11-11 20:36:18 -0500 )edit

@Herick Please open a new question, this one is quite old.

tfoote gravatar image tfoote  ( 2013-11-12 06:24:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-06 02:57:15 -0500

Daniel Stonier gravatar image

Your issue might be into this problem also: https://github.com/turtlebot/turtlebot/issues/57

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-04 23:20:28 -0500

Seen: 984 times

Last updated: Mar 04 '13