Ask Your Question
0

Problem with stage + rviz (segmentation fault)

asked 2013-02-23 12:36:31 -0500

updated 2013-02-23 12:38:09 -0500

Hi, i'm simulating an array of robots with laser and I want to see all laser scans in Rviz.

After start roscore, if I rosrun stageros node and then rviz node, the problem appears:

gustavo@gustavo-ProBook:~$ rosrun rviz rviz 
[ INFO] [1361665790.163219703]: rviz version 1.9.20
[ INFO] [1361665790.163372795]: compiled against OGRE version 1.7.4 (Cthugha)
[ WARN] [1361665794.846113178, 38.500000000]: OGRE EXCEPTION(7:InternalErrorException): Cannot compile GLSL high-level shader : rviz/box.geom invalid valueCannot compile GLSL high-level shader : rviz/box.geom invalid value in GLSLProgram::compile at /build/buildd/ogre-1.7.4/RenderSystems/GL/src/GLSL/src/OgreGLSLExtSupport.cpp (line 65)
[ WARN] [1361665794.858389102, 38.500000000]: OGRE EXCEPTION(2:InvalidParametersException): Named constants have not been initialised, perhaps a compile error. in GpuProgramParameters::_findNamedConstantDefinition at /build/buildd/ogre-1.7.4/OgreMain/src/OgreGpuProgramParams.cpp (line 1425)
[ WARN] [1361665794.865810096, 38.500000000]: OGRE EXCEPTION(2:InvalidParametersException): Named constants have not been initialised, perhaps a compile error. in GpuProgramParameters::_findNamedConstantDefinition at /build/buildd/ogre-1.7.4/OgreMain/src/OgreGpuProgramParams.cpp (line 1425)
[ WARN] [1361665794.866371060, 38.500000000]: OGRE EXCEPTION(2:InvalidParametersException): Named constants have not been initialised, perhaps a compile error. in GpuProgramParameters::_findNamedConstantDefinition at /build/buildd/ogre-1.7.4/OgreMain/src/OgreGpuProgramParams.cpp (line 1425)
[ WARN] [1361665795.010072435, 38.600000000]: OGRE EXCEPTION(7:InternalErrorException): Cannot compile GLSL high-level shader : rviz/pass_pos_color.vert Cannot compile GLSL high-level shader : rviz/pass_pos_color.vert 0:1(15): preprocessor error: syntax error, unexpected IDENTIFIER, expecting NEWLINE
 in GLSLProgram::compile at /build/buildd/ogre-1.7.4/RenderSystems/GL/src/GLSL/src/OgreGLSLExtSupport.cpp (line 65)
Violación de segmento (`core' generado)

The curious part is that if I rosrun rviz node first and then start stageros node, everything is fine.

So, where can I report this bug? Any solution?

EDIT: I'm using ROS groovy, Ubuntu 12.04

edit retag flag offensive close merge delete

Comments

I have the same problem with you!!!

Lili Meng gravatar image Lili Meng  ( 2014-03-26 14:34:56 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-02-24 07:29:20 -0500

updated 2013-02-25 08:57:58 -0500

Hi! This bug is not present in the lastest version of Rviz (1.9.24), I have to install it from github and it runs fine.

edit flag offensive delete link more
1

answered 2013-02-24 03:32:53 -0500

SL Remy gravatar image

You can report issues related to stage at rtv/Stage.

I'd also suggest running stageros with gdb to get more information about the segfault.

edit flag offensive delete link more

Comments

Thanks for your answer! Actually the segfault appears running rviz node.

gustavo.velascoh gravatar image gustavo.velascoh  ( 2013-02-24 05:00:54 -0500 )edit
1

In that case run rviz under gdb, and report the bug here: https://github.com/ros-visualization/rviz/issues

joq gravatar image joq  ( 2013-02-24 05:06:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-23 12:36:31 -0500

Seen: 761 times

Last updated: Feb 25 '13