ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

openni_tracker has problem opening database/parameter File

asked 2013-02-21 16:01:45 -0500

rhololkeolke gravatar image

updated 2016-10-24 09:09:05 -0500

ngrennan gravatar image

I'm trying to use the openni_launch and openni_tracker packages. I made a package called kinect_hmi and a launch file which launches both the openni_launch file and openni_track. When I tested this previously I could view he PointCloud2 data and the tf data in RVIZ. However, today when I started up the code I get the following error.

Error opening database/parameters file.

The point cloud data still shows up in RVIZ, but the skeleton tracking does not seem to be working. I tried starting roscore, openni_launch, and openni_tracker separately to see if my launch file was the problem but it didn't help. I have no idea why it isn't working all of the sudden.

Just in case here is my launch file

  <include file="$(find kinect_hmi)/launch/camera_topics.launch" />
  <node pkg="tf" type="static_transform_publisher" name="depth_to_camera_broadcaster" args="0 0 0 0 0 0 camera_link openni_depth_frame 100" />
  <node name="openni_tracker" pkg="openni_tracker" type="openni_tracker" respawn="true"/>

The camera topics launch file is the following

  <include file="$(find openni_launch)/launch/openni.launch" />

I thought maybe that the parameter server wasn't running so I tried the rosparam list command. However, the command returns a long list of things so I'm assuming that the parameter server is running.

My question is: Why is this happening and how do I fix it?

Thanks in advance

edit retag flag offensive close merge delete


Have you tried reinstalling the openni package? Maybe you can just start again.

Josch gravatar image Josch  ( 2013-03-04 19:48:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-03-15 00:16:39 -0500

PNowak gravatar image

Hello. I have same problem, but i managed to fix it. Problem is in primesense library. Some file don't have privileges. U need go to:


and set privileges to folder Data. I did it through nautilus and my problem was fixed.

Hope it will help you too.

edit flag offensive delete link more


The system I'm developing on is erased each reboot. Unfortunately I rebooted before I could test this solution, but because rebooting (which would reset all file permissions to when they were working) fixed the problem I'm accepting this answer as correct.

rhololkeolke gravatar image rhololkeolke  ( 2013-03-20 23:56:50 -0500 )edit

This answer fixed my error. Strange, I've been using the NITE packages for a long time, and I've never seen this error before. I wonder what caused it?

jarvisschultz gravatar image jarvisschultz  ( 2015-11-06 06:44:02 -0500 )edit

Question Tools

1 follower


Asked: 2013-02-21 16:01:45 -0500

Seen: 1,055 times

Last updated: Mar 15 '13