Ask Your Question
2

Openni in groovy: Error when trying to launch openni_tracker

asked 2013-02-15 01:13:44 -0500

dinsn gravatar image

updated 2016-10-24 08:35:03 -0500

ngrennan gravatar image

Hi,

I'm new to ROS and just managed to install Groovy on Ubuntu 12.04. After installing the openni packages I'm able to receive the disparity and RGB image from my Kinect, but if I want to start the skeleton tracker by calling rosrun openni_tracker openni_tracker, I just get the error

[ERROR] [1360932563.459904042]: Find user generator failed: This operation is invalid!

Has anybody ever experienced the same error and knows how to fix it?

Thanks for your help!

edit retag flag offensive close merge delete

2 Answers

Sort by ┬╗ oldest newest most voted
0

answered 2013-05-23 06:00:58 -0500

Juan gravatar image

updated 2013-05-23 12:56:10 -0500

Ubuntu 12.10, ROS Groovy.

I had a bit of trouble downloading the correct version of NITE.

The first couple of time I tried:
1. OpenNI-Bin-Dev-Linux-x64-v1.5.4.0.tar.zip
2. NiTE-Linux-x64-2.0.0.tar1.zip

Both of which had no uninstall.sh files. Only the install.sh file.

Finally, I found [NITE-Bin-Linux-x64-v1.5.2.21.tar.zip] (http://www.openni.org/wp-content/uploads/2012/12/NITE-Bin-Linux-x64-v1.5.2.21.tar.zip)

This last version had the uninstall file. After running it as sudo and then running the install.sh file, everything worked.

edit flag offensive delete link more
0

answered 2013-02-16 01:45:20 -0500

da-na gravatar image

Hi! I had the same issue but on ROS Fuerte with Ubuntu 12.04 x86. I followed steps from this that Stephanie.M suggested in some other post (my karma is to small to publish links), namely:

"In order to solve it : 1) go to openni page 2) download old nite from openni-sdk-history ( NITE 1.5.2.21 ) 3) "Unzip" 4) "Ungz" 5) Launch the uninstall script first ! 6) Launch the install script"

It worked for me :)

Cheers, da-na

edit flag offensive delete link more

Comments

Thanks for the suggestion. I've already tried this, but afterwards I was not even able to connect to my Kinect any more (I always received the message "No devices connected..."). Had to completely delete all openni components and reinstall ROS in order to be able to connect again.

dinsn gravatar imagedinsn ( 2013-02-19 22:08:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-15 01:13:44 -0500

Seen: 1,300 times

Last updated: May 23 '13