Ask Your Question
0

Kinect depth registration not working on Fuerte and Groovy

asked 2013-02-11 08:44:02 -0500

Jbot gravatar image

updated 2014-04-20 14:09:47 -0500

ngrennan gravatar image

Hi,

I'm trying to use a Microsoft Kinect with openni_launch but it does not seem to works when I activate the depth registration.

Depending on the ROS version I use, it works... or not !

I have 3 configurations :

  • First one (depth registration works and output the correct point cloud) :

Ubuntu 11.04 / ROS-electric

joffrey@joffrey-laptop:~$ ls -lh /dev/bus/usb/002
total 0
crw-rw-r-- 1 root root  189, 128 2013-02-10 16:46 001
crw-rw-r-- 1 root root  189, 129 2013-02-10 16:46 002
crw-rw-rw- 1 root video 189, 130 2013-02-10 16:46 003
crw-rw-rw- 1 root video 189, 131 2013-02-10 16:46 004
crw-rw-rw- 1 root video 189, 132 2013-02-10 16:47 005

Then I launch the openni_launch :

[ INFO] [1360511347.490430446]: Number devices connected: 1
[ INFO] [1360511347.490702621]: 1. device on bus 002:05 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00365A11502110A'
[ INFO] [1360511347.491936313]: Searching for device with index = 1
[ INFO] [1360511347.558953638]: Opened 'Xbox NUI Camera' on bus 2:5 with serial number 'A00365A11502110A'
[ INFO] [1360511347.580108921]: rgb_frame_id = '/camera_rgb_optical_frame'
[ INFO] [1360511347.580986069]: depth_frame_id = '/camera_depth_optical_frame'
  • Second one (depth registration does not works and only output a no-corrected pointCloud) :

Ubuntu 12.04 / ROS-fuerte

jbot@jbot-computer:~$ ls -lh /dev/bus/usb/001
total 0
crw-rw-r-- 1 root root  189, 0 Feb 11 20:23 001
crw-rw-r-- 1 root root  189, 1 Feb 11 20:23 002
crw-rw-rw- 1 root video 189, 3 Feb 11 20:23 004
crw-rw-rw- 1 root audio 189, 4 Feb 11 20:23 005
crw-rw-rw- 1 root video 189, 5 Feb 11 20:23 006

Then I launch the openni_launch :

[ INFO] [1360610712.386774453]: Number devices connected: 1
[ INFO] [1360610712.387187736]: 1. device on bus 001:06 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00365A11502110A'
[ INFO] [1360610712.388781935]: Searching for device with index = 1
[ INFO] [1360610712.457443795]: Opened 'Xbox NUI Camera' on bus 1:6 with serial number 'A00365A11502110A'
[ INFO] [1360610712.515264262]: rgb_frame_id = '/camera_rgb_optical_frame'
[ INFO] [1360610712.515401560]: depth_frame_id = '/camera_depth_optical_frame'
  • Third one (depth registration does not works and only output a no-corrected pointCloud) :

Ubuntu 12.04 / ROS-groovy

jbot@jbot-carole:~$ ls -lh /dev/bus/usb/001
total 0
crw-rw-r-- 1 root root  189, 0 Feb 11 21:18 001
crw-rw-r-- 1 root root  189, 1 Feb 11 21:18 002
crw-rw-r-- 1 root root  189, 2 Feb 11 21:18 003
crw-rw-r-- 1 root root  189, 3 Feb 11 21:20 004
crw-rw-rw- 1 root video 189, 4 Feb 11 21:20 005
crw-rw-rw- 1 root audio 189, 5 Feb 11 21:20 006
crw-rw-rw- 1 root video 189, 6 Feb 11 21:20 007

Then I launch the openni_launch :

[ INFO] [1360614100.569994039]: Number devices connected: 1
[ INFO] [1360614100.570205756]: 1. device on bus 001:07 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00365A11502110A'
[ INFO] [1360614100.571850761]: Searching for device with index = 1
[ INFO] [1360614100.620895093]: Opened 'Xbox NUI Camera' on bus 1:7 with serial number 'A00365A11502110A'
[ INFO] [1360614100.650978646]: rgb_frame_id = '/camera_rgb_optical_frame'
[ INFO ...
(more)
edit retag flag offensive close merge delete

Comments

1

How do you launch your openni ? Do you use the option "depth_registration:=true" in Groovy ? What version of NITE do you use ?

Stephane.M gravatar imageStephane.M ( 2013-02-12 05:10:49 -0500 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2013-02-12 05:14:59 -0500

You should precise the exact commands you used for each one.

In Electric, even if you did just launch openni.launch, you were able to visualize some XYZRGB, with a bad registration, but still you had something. Activating it was just allowing you to have a better registration.

I can't say anything in Fuerte, I don't use it.

However, I can confirm that in Groovy (Ubuntu 12.10 and NITE 1.5.2.21) the depth_registration is false by default, thus preventing completely from visualizing XYZRGB. In order to launch it "automatically", use the following command :

roslaunch openni_launch openni.launch depth_registration:=true

I think your problem come from the NITE. Indeed, I experienced similar problems when I was using the last NITE under Groovy : I saw that I was not able to have any RGB information from the kinect (try in Rviz).

In order to solve it : 1) got to http://www.openni.org/openni-sdk/openni-sdk-history-2/ 2) Download NITE 1.5.2.21 3) "Unzip" 4) "Ungz" 5) Launch the uninstall script first ! 6) Launch the install script

It should work after that... Let me know !

edit flag offensive delete link more

Comments

This didn't work for me with Groovy, Ubuntu 12.04, and NITE 1.5.2.21. The topic is either present and unregistered, or missing. Do we need to do something else to point openni at the new NITE? When I ran the uninstall, it didn't find /usr/lib/libXn*so that it was trying to remove.

KevinNickels gravatar imageKevinNickels ( 2013-10-01 06:19:37 -0500 )edit
0

answered 2013-02-12 02:47:40 -0500

jcc gravatar image

at least for me since Electric the registration seams to be on by default (even if it don't show that), and if you tried to turn on it does't give any pointcloud (bug?), but with the registration off you can view XYZRGB Pointclouds in rviz and access the "/camera/depth_registered/points" topic

edit flag offensive delete link more

Comments

With the registration off, I can view the XYZRGB Pointclouds in rviz and access the "/camera/depth_registered/points" topic BUT the RGB is misaligned with the distance.

Jbot gravatar imageJbot ( 2013-02-12 03:12:44 -0500 )edit

I didn't check the alignment, but seams it's the same problem as mine. You just install the ros-VERSION-openni-camera and openni-launch ? No OpenNI/NITE standalone code?

jcc gravatar imagejcc ( 2013-02-12 06:24:20 -0500 )edit

Yes I just install the ros versions. But yesterday I have installed OpenNI from sources and now it works. I find the "solution" here : http://answers.ros.org/question/53706/registered-depth-image-is-black/ . It's not really a good solution because I have to install it manually but it works on FUERTE

Jbot gravatar imageJbot ( 2013-02-13 03:20:17 -0500 )edit
0

answered 2013-02-16 01:47:25 -0500

da-na gravatar image

Hi!

I used your advice Stephanie.M and it worked for me on Ubuntu 12.04 x86 with ROS Fuerte. I had problems with openni_tracker, but now after reinstalling NITE it seems to work :) Thank you for your advice!

Cheers, da-na

edit flag offensive delete link more

Comments

Glad it worked for you :-) It seems however that it didn't work for J-bot... But at least he found another solution :-) Have a good day, Steph ps: it's Stéphane, not Stéphanie ;-)

Stephane.M gravatar imageStephane.M ( 2013-02-17 20:20:46 -0500 )edit

Sorry for the troublesome >i< Stephane.M !!

da-na gravatar imageda-na ( 2013-03-10 11:49:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-11 08:44:02 -0500

Seen: 1,910 times

Last updated: Feb 16 '13