Ask Your Question
1

[Error] nodelet pcl/* crash

asked 2013-02-09 07:01:20 -0500

jcc gravatar image

Hi,

I've switch to Groovy and we i tried to run my launch file with calls a pcl nodelet, the nodelet crashes.

I tried to load it manualy (command-line) and i'm getting the same error.

I do

$ rosrun nodelet nodelet manager __name:=nodelet_manager

And get

[ INFO] [1360435647.453864706]: Initializing nodelet with 8 worker threads.

all OK.

In another terminal i run:

$ rosrun nodelet nodelet load pcl/PassThrough nodelet_manager ~input:="/camera/depth_registered/points"

and i get:

[ INFO] [1360435704.541942377]: Loading nodelet /pcl_PassThrough of type pcl/PassThrough to manager nodelet_manager with the following remappings:
[ INFO] [1360435704.542172024]: /pcl_PassThrough/input -> /camera/depth_registered/points
[FATAL] [1360435704.550783258]: Service call failed!

and on the 1st terminal (nodelet manager) i get

[ERROR] [1360435704.550185447, 1358879347.082131986]: Failed to load nodelet [/pcl_PassThrough] of type [pcl/PassThrough]: According to the loaded plugin descriptions the class pcl/PassThrough with base class type nodelet::Nodelet does not exist. Declared types are  depth_image_proc/convert_metric depth_image_proc/disparity depth_image_proc/point_cloud_xyz depth_image_proc/point_cloud_xyzrgb depth_image_proc/register image_proc/crop_decimate image_proc/debayer image_proc/rectify image_view/disparity image_view/image nodelet_tutorial_math/Plus openni_camera/driver stereo_image_proc/disparity stereo_image_proc/point_cloud stereo_image_proc/point_cloud2

This happens even without running anything that publish the /camera/depth_registered/points. I can make this happen with just 3 terminals, the roscore and the two i described here.

Also this happens for the Passtrough, VoxelGrid, StatisticalOutlierRemoval

Thanks

edit retag flag offensive close merge delete

Comments

I get the same error using the very latest Groovy debs (pushed just last night) and Ubuntu 12.04LTS. Everything was working fine under Fuerte. Ticket submitted here https://github.com/ros-perception/perception_pcl/issues/7.

Pi Robot gravatar image Pi Robot  ( 2013-03-04 05:30:53 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-03-07 15:08:39 -0500

Pi Robot gravatar image

This has now been fixed in the latest Groovy debs. See the (now closed) ticket at: https://github.com/ros-perception/perception_pcl/issues/7.

edit flag offensive delete link more
0

answered 2013-02-11 09:25:40 -0500

jcc gravatar image

updated 2013-02-12 02:51:20 -0500

Ok,

Or i'm doing someting very stupid or the pcl filter nodelet is wrong, (has a bug). I format the linux partition and installed again the Ubuntu 12.04 32 bits. On a fresh install of ROS Groovy (exactly like the instructions) i run the same commands that i put on the OP and i get the same thing! Even without installing openni-camera or openni-launch.

I just test it now. I don't even need to remap the input, simply doing

rosrun nodelet nodelet load pcl/PassThrough nodelet_manager

makes the same error.

On a fresh install of Fuerte it runs ok!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-09 07:01:20 -0500

Seen: 798 times

Last updated: Mar 07 '13